summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsuliman altassan2020-06-04 10:07:36 +0300
committersuliman altassan2020-06-04 10:07:36 +0300
commit137b4ba060ff0b2253fe11ba625e75462e789c25 (patch)
tree46f3dc697af4dd17aaf357fd27e30a1a52e09130
downloadaur-137b4ba060ff0b2253fe11ba625e75462e789c25.tar.gz
ALUSUS PROGRAMMING LANGUAGE
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b73c3eafb28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = alusus
+ pkgdesc = ALUSUS PROGRAMMING LANGUAGE - لغة الأسس البرمجية
+ pkgver = 0.6.1
+ pkgrel = 0
+ url = https://alusus.org/
+ arch = x86_64
+ license = custom
+ depends = python
+ depends = python-pip
+ source = https://github.com/sulimanp/Alusus/archive/master.zip
+ md5sums = aece76ac530dafcd5561bd354d46ae05
+
+pkgname = alusus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37850b28af3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: suliman altassan <suliman.p2019@gmail.com>
+
+pkgname=alusus
+pkgver=0.6.1
+pkgrel=0
+pkgdesc="ALUSUS PROGRAMMING LANGUAGE - لغة الأسس البرمجية"
+arch=('x86_64')
+url="https://alusus.org/"
+license=('custom')
+depends=('python' 'python-pip')
+source=('https://github.com/sulimanp/Alusus/archive/master.zip')
+md5sums=('aece76ac530dafcd5561bd354d46ae05')
+
+build() {
+ cd "$srcdir/Alusus-master"
+ ./Tools/build.sh --bloc . --iloc .
+if [ -e "./Builds/Dependencies/llvm-10.0.0.install" ]; then
+ cmake Sources -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX="$pkgdir/opt/Alusus" -DLLVM_PATH=./Builds/Dependencies/llvm-10.0.0.install
+ make -j $(nproc)
+fi
+}
+
+package() {
+ cd "$srcdir/Alusus-master"
+ make install -j $(nproc)
+}
+
+# ==> ERROR: One or more files did not pass the validity check!
+# makepkg -g >> PKGBUILD \ No newline at end of file