summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Mariański2022-01-23 19:58:47 +0100
committerŁukasz Mariański2022-01-23 19:58:47 +0100
commit703353528bc82eccfc0307e7712fe8609a16affc (patch)
tree46e974996c56cf9ef3f06383ee52aac0926b36ea
parent05ffc5000f5bd6ce70625a1e76f64e2cab948ea0 (diff)
downloadaur-703353528bc82eccfc0307e7712fe8609a16affc.tar.gz
v17
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
-rw-r--r--alvr.patch65
3 files changed, 14 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 960c8e17ce3e..287f9db39154 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alvr
pkgdesc = Experimental Linux version of ALVR. Stream VR games from your PC to your headset via Wi-Fi.
- pkgver = 16.0.0.r0.gece4d74c
- pkgrel = 4
+ pkgver = 17.0.0.r0.ga30b2ae1
+ pkgrel = 1
url = https://github.com/alvr-org/ALVR
arch = x86_64
license = MIT
@@ -16,9 +16,7 @@ pkgbase = alvr
depends = libunwind
provides = alvr
conflicts = alvr
- source = alvr::git+https://github.com/alvr-org/ALVR.git#tag=v16.0.0
- source = alvr.patch
+ source = alvr::git+https://github.com/alvr-org/ALVR.git#tag=v17.0.0
md5sums = SKIP
- md5sums = 8a2815f250ac231bb7252599771352f6
pkgname = alvr
diff --git a/PKGBUILD b/PKGBUILD
index 67fb5316a3c3..5b35a073cf76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Łukasz Mariański <lmarianski dot protonmail dot com>
pkgname=alvr
-pkgver=16.0.0.r0.gece4d74c
-pkgrel=4
+pkgver=17.0.0.r0.ga30b2ae1
+pkgrel=1
pkgdesc="Experimental Linux version of ALVR. Stream VR games from your PC to your headset via Wi-Fi."
arch=('x86_64')
url="https://github.com/alvr-org/ALVR"
@@ -11,10 +11,9 @@ depends=('vulkan-driver' 'ffmpeg-vulkan' 'gtk3' 'libunwind')
makedepends=('git' 'cargo' 'clang' 'imagemagick' 'vulkan-headers')
provides=("${pkgname}")
conflicts=("${pkgname}")
-source=('alvr'::'git+https://github.com/alvr-org/ALVR.git#tag=v16.0.0'
- "${pkgname}.patch")
-md5sums=('SKIP'
- '8a2815f250ac231bb7252599771352f6')
+_tag="v17.0.0"
+source=('alvr'::"git+https://github.com/alvr-org/ALVR.git#tag=${_tag}")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname}"
@@ -24,7 +23,7 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname}"
- patch --strip=1 --input=$srcdir/${pkgname}.patch
+ sed -i 's:../../../lib64/libalvr_vulkan_layer.so:libalvr_vulkan_layer.so:' alvr/vulkan-layer/layer/alvr_x86_64.json
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
@@ -34,12 +33,12 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- # export ALVR_ROOT_DIR=/usr
+ export ALVR_ROOT_DIR=/usr
- # export ALVR_LIBRARIES_DIR=$ALVR_ROOT_DIR/lib/
+ export ALVR_LIBRARIES_DIR=$ALVR_ROOT_DIR/lib/
- # export ALVR_OPENVR_DRIVER_ROOT_DIR=$ALVR_LIBRARIES_DIR/steamvr/alvr/
- # export ALVR_VRCOMPOSITOR_WRAPPER_DIR=$ALVR_LIBRARIES_DIR/alvr/
+ export ALVR_OPENVR_DRIVER_ROOT_DIR=$ALVR_LIBRARIES_DIR/steamvr/alvr/
+ export ALVR_VRCOMPOSITOR_WRAPPER_DIR=$ALVR_LIBRARIES_DIR/alvr/
cargo build \
--frozen \
@@ -94,7 +93,7 @@ package() {
install -d $pkgdir/usr/share/icons/hicolor/{16x16,32x32,48x48,64x64,128x128,256x256}/apps/
cp -r icons/* $pkgdir/usr/share/icons/
- install -Dm644 packaging/firewall/$pkgname-firewalld.xml "$pkgdir/usr/lib/firewalld/services/${pkgname}.xml"
+ install -Dm644 packaging/firewall/$pkgname-firewalld.xml "$pkgdir/usr/lib/firewalld/services/${_pkgname}.xml"
install -Dm644 packaging/firewall/ufw-$pkgname -t "$pkgdir/etc/ufw/applications.d/"
install -Dm755 packaging/firewall/alvr_fw_config.sh -t "$pkgdir/usr/lib/alvr/"
diff --git a/alvr.patch b/alvr.patch
deleted file mode 100644
index 39dbdee46c4f..000000000000
--- a/alvr.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff --git a/alvr/filesystem-layout/src/lib.rs b/alvr/filesystem-layout/src/lib.rs
-index 82c367f0..2d3e127c 100644
---- a/alvr/filesystem-layout/src/lib.rs
-+++ b/alvr/filesystem-layout/src/lib.rs
-@@ -52,9 +52,9 @@ lazy_static! {
- }
- } else if cfg!(target_os = "linux") {
- Layout {
-- openvr_driver_dir: PathBuf::from("lib64/alvr"),
-+ openvr_driver_dir: PathBuf::from("lib/steamvr/alvr"),
- presets_dir: PathBuf::from("share/alvr/presets"),
-- vrcompositor_wrapper: PathBuf::from("libexec/alvr/vrcompositor-wrapper"),
-+ vrcompositor_wrapper: PathBuf::from("lib/alvr/vrcompositor-wrapper"),
- launcher_exe: PathBuf::from("bin/alvr_launcher"),
- dashboard_resources_dir: PathBuf::from("share/alvr/dashboard"),
- }
-diff --git a/alvr/server/cpp/platform/linux/ffmpeg_helper.h b/alvr/server/cpp/platform/linux/ffmpeg_helper.h
-index 4c91e20b..f4ea9b51 100644
---- a/alvr/server/cpp/platform/linux/ffmpeg_helper.h
-+++ b/alvr/server/cpp/platform/linux/ffmpeg_helper.h
-@@ -46,6 +46,7 @@ public:
- struct dispatch
- {
- PFN_vkImportSemaphoreFdKHR vkImportSemaphoreFdKHR;
-+ int getVkHeaderVersion() const { return VK_HEADER_VERSION; }
- };
-
- VkContext(const char* device, AVDictionary* opt = nullptr);
-diff --git a/alvr/vrcompositor-wrapper/src/main.rs b/alvr/vrcompositor-wrapper/src/main.rs
-index 327ce07b..0dcefa28 100644
---- a/alvr/vrcompositor-wrapper/src/main.rs
-+++ b/alvr/vrcompositor-wrapper/src/main.rs
-@@ -5,7 +5,7 @@ fn main() {
- Ok(path) => path
- .parent()
- .unwrap()
-- .join("../../share/vulkan/explicit_layer.d"),
-+ .join("/usr/share/vulkan/explicit_layer.d/"),
- Err(err) => panic!("Failed to read vrcompositor symlink: {}", err),
- };
- std::env::set_var("VK_LAYER_PATH", layer_path);
-diff --git a/alvr/vulkan-layer/layer/alvr_x86_64.json b/alvr/vulkan-layer/layer/alvr_x86_64.json
-index d0044b89..8706f699 100644
---- a/alvr/vulkan-layer/layer/alvr_x86_64.json
-+++ b/alvr/vulkan-layer/layer/alvr_x86_64.json
-@@ -3,7 +3,7 @@
- "layer" : {
- "name": "VK_LAYER_ALVR_capture",
- "type": "GLOBAL",
-- "library_path": "../../../lib64/libalvr_vulkan_layer.so",
-+ "library_path": "libalvr_vulkan_layer.so",
- "api_version": "1.0.68",
- "implementation_version": "1",
- "description": "ALVR display intercept layer",
-diff --git a/packaging/selinux/alvr.fc b/packaging/selinux/alvr.fc
-index ea28c416..27f5119a 100644
---- a/packaging/selinux/alvr.fc
-+++ b/packaging/selinux/alvr.fc
-@@ -1,4 +1,4 @@
- /usr/bin/alvr_launcher gen_context(system_u:object_r:alvr_exec_t,s0)
--/usr/lib(64)?/alvr(/.*)? gen_context(system_u:object_r:alvr_lib_t,s0)
-+/usr/lib(64)?/steamvr/alvr(/.*)? gen_context(system_u:object_r:alvr_lib_t,s0)
- /usr/lib(64)?/libalvr_vulkan_layer.so gen_context(system_u:object_r:alvr_lib_t,s0)
--/usr/libexec/alvr(/.*)? gen_context(system_u:object_r:alvr_exec_t,s0)
-+/usr/bin/alvr(/.*)? gen_context(system_u:object_r:alvr_exec_t,s0)