summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiepee2021-06-26 09:06:38 +0200
committerMiepee2021-06-26 09:06:38 +0200
commit00ab2beb09d207a20ab176c07aac538b0a6e6623 (patch)
tree891cc1759bbb606c9072718427f8f0c8bb58eef8
downloadaur-00ab2beb09d207a20ab176c07aac538b0a6e6623.tar.gz
first init of am2rlauncher-git
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD52
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93bef98b3c70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = am2rlauncher-git
+ pkgdesc = Application for installing the latest Community Updates, APKs and Mods for AM2R.
+ pkgver = 2.1.0.r2.e97d335
+ pkgrel = 1
+ url = https://github.com/AM2R-Community-Developers/AM2RLauncher
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = dotnet-runtime>=5
+ makedepends = dotnet-sdk>=5
+ depends = dotnet-runtime
+ depends = gtk3
+ depends = libappindicator-gtk3
+ depends = webkit2gtk
+ depends = openssl
+ depends = icu
+ depends = xdelta3
+ depends = fuse2
+ optdepends = jre-openjdk: Creating APKs
+ conflicts = am2rlauncher
+ options = !strip
+ source = git+https://github.com/AM2R-Community-Developers/AM2RLauncher
+ md5sums = SKIP
+
+pkgname = am2rlauncher-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff90e4c9f5e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Miepee <janbidler00 at tutanota dot com>
+pkgname=am2rlauncher-git
+pkgver=2.1.0.r2.e97d335
+pkgrel=1
+pkgdesc="Application for installing the latest Community Updates, APKs and Mods for AM2R."
+arch=(x86_64)
+url="https://github.com/AM2R-Community-Developers/AM2RLauncher"
+license=('GPL3')
+depends=('dotnet-runtime' 'gtk3' 'libappindicator-gtk3' 'webkit2gtk' 'openssl' 'icu' 'xdelta3' 'fuse2')
+makedepends=('git' 'dotnet-runtime>=5' 'dotnet-sdk>=5')
+optdepends=('jre-openjdk: Creating APKs')
+conflicts=('am2rlauncher')
+source=("git+$url")
+md5sums=(SKIP)
+options=(!strip)
+# ^ doesn't correctly publish without
+
+pkgver() {
+ cd "AM2RLauncher"
+ printf %s "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g')"
+}
+
+build() {
+ cd "AM2RLauncher/AM2RLauncher/"
+ dotnet publish AM2RLauncher.Gtk -p:PublishSingleFile=true -c release -r ubuntu.18.04-x64 --no-self-contained
+}
+
+package() {
+
+ # remame files properly
+ mv -f AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net5.0/ubuntu.18.04-x64/publish/AM2RLauncher.Gtk AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net5.0/ubuntu.18.04-x64/publish/AM2RLauncher
+ mv -f AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net5.0/ubuntu.18.04-x64/publish/AM2RLauncher.Gtk.pdb AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net5.0/ubuntu.18.04-x64/publish/AM2RLauncher.pdb
+
+ mkdir -p "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/opt/am2rlauncher/"
+
+ cp -Rf AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net5.0/ubuntu.18.04-x64/publish/* "$pkgdir/opt/am2rlauncher/"
+ cp -f "AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/icon64.ico" $pkgdir/opt/am2rlauncher/AM2RLauncher.ico
+ cd "$pkgdir/usr/bin/"
+ ln -sf "/opt/am2rlauncher/AM2RLauncher"
+
+ # Adding desktop entry
+ mkdir -p "$pkgdir/usr/share/applications/"
+ echo "[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=AM2RLauncher
+Comment=A front-end application that simplifies installing the latest AM2R-Community-Updates, creating APKs for Android use, as well as Mods for AM2R.
+Exec=AM2RLauncher
+Icon=/opt/am2rlauncher/AM2RLauncher.ico
+Terminal=false" > $pkgdir/usr/share/applications/am2rlauncher.desktop
+}