summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene 'Vindex' Stulin2022-09-15 23:52:27 +0300
committerEugene 'Vindex' Stulin2022-09-15 23:52:27 +0300
commit3c8ab861ad6cd10e8d9e9124efc3fa0573d8ad37 (patch)
tree2abc95ec07b344906db549197cb1bf1c553678a2
parent8cac465d3c0192d8d9effe9b462a3f62570643ef (diff)
downloadaur-3c8ab861ad6cd10e8d9e9124efc3fa0573d8ad37.tar.gz
Fix compiler
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4de34bf605a2..8ab3c3fa37b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: Eugene 'Vindex' Stulin <tech.vindex@gmail.com>
-pkgname=amalthea-gdc
+DC=gdc
+DC_PKG=gcc-d
+
+pkgname=amalthea-${DC}
pkgver=1.2.1
pkgrel=1
-pkgdesc="Small general library for the D programming language, version for GDC"
+pkgdesc="Small general library for the D programming language, version for ${DC^^}"
arch=('x86_64')
url="https://gitlab.com/os-18/amalthea"
license=('Boost or LGPL3')
makedepends=('make' 'bash' 'chrpath' 'lsb-release' 'glib2')
-depends=('gcc-d')
+depends=("${DC}")
source=("$pkgname-$pkgver.tar.gz::$url/-/archive/v$pkgver/amalthea-v$pkgver.tar.gz")
sha256sums=('f9ec27a8859a10605e51a6b6f4096c57a59e759a293c57aca73e9076b2941ae6')
build() {
cd "amalthea-v$pkgver"
- make || return 1
+ make DC=${DC} || return 1
}
package() {
- GDC_VERSION=`gdc -dumpversion`
- INCDIR=lib/gcc/x86_64-pc-linux-gnu/${GDC_VERSION}/include/d/
cd "amalthea-v$pkgver"
- make DESTDIR=$pkgdir INCDIR=${INCDIR} install || return 1
+ make DESTDIR=$pkgdir install DC=${DC} || return 1
}