summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene 'Vindex' Stulin2023-03-17 00:28:05 +0300
committerEugene 'Vindex' Stulin2023-03-17 00:28:05 +0300
commit447d1db7216ad80d8edf7c173bc72aea752cc742 (patch)
treee72878e1213415b8c88005b7af07db0746d919e2
parent04ccc640e75c5fff9eddc5e2d41f65d956c05c6f (diff)
downloadaur-447d1db7216ad80d8edf7c173bc72aea752cc742.tar.gz
1.4.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e796429c8a7..002fdcca7be1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = amalthea-gdc
pkgdesc = Small general library for the D programming language, version for GDC
- pkgver = 1.3.0
+ pkgver = 1.4.0
pkgrel = 1
url = https://gitlab.com/os-18/amalthea
arch = x86_64
license = Boost or LGPL3
- makedepends = make
makedepends = bash
makedepends = chrpath
makedepends = lsb-release
+ makedepends = pkgconf
makedepends = glib2
+ makedepends = gcc-d
depends = gcc-d
- source = amalthea-gdc-1.3.0.tar.gz::https://gitlab.com/os-18/amalthea/-/archive/v1.3.0/amalthea-v1.3.0.tar.gz
- sha256sums = 00bb6785f7b922ec280525b7097dab268e18046864cf4a15de3e1722204ce9d9
+ source = amalthea-gdc-1.4.0.tar.gz::https://gitlab.com/os-18/amalthea/-/archive/v1.4.0/amalthea-v1.4.0.tar.gz
+ sha256sums = d67e3a1dcba7a4f524916ea3ecfbba4ec7519ecce478e3f441b514773e36b1f0
pkgname = amalthea-gdc
-
diff --git a/PKGBUILD b/PKGBUILD
index d27d80edc803..334af2e46789 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
# Maintainer: Eugene 'Vindex' Stulin <tech.vindex@gmail.com>
+PROJECT=amalthea
+DESCR="Small general library for the D programming language"
DC=gdc
DC_PKG=gcc-d
-
-pkgname=amalthea-${DC}
-pkgver=1.3.0
+makedepends=("bash" "chrpath" "lsb-release" "pkgconf" "glib2" "gcc-d")
+depends=("gcc-d")
+pkgver=1.4.0
pkgrel=1
-pkgdesc="Small general library for the D programming language, version for ${DC^^}"
-arch=('x86_64')
-url="https://gitlab.com/os-18/amalthea"
-license=('Boost or LGPL3')
-makedepends=('make' 'bash' 'chrpath' 'lsb-release' 'glib2' 'pkgconf')
-depends=("${DC}")
-source=("$pkgname-$pkgver.tar.gz::$url/-/archive/v$pkgver/amalthea-v$pkgver.tar.gz")
-sha256sums=('00bb6785f7b922ec280525b7097dab268e18046864cf4a15de3e1722204ce9d9')
+license=("Boost or LGPL3")
+
+pkgname=${PROJECT}-${DC}
+pkgdesc="${DESCR}, version for ${DC^^}"
+arch=("x86_64")
+url="https://gitlab.com/os-18/${PROJECT}"
+TARBALL=$pkgname-$pkgver.tar.gz
+source=("$TARBALL::$url/-/archive/v$pkgver/${PROJECT}-v$pkgver.tar.gz")
+sha256sums=("d67e3a1dcba7a4f524916ea3ecfbba4ec7519ecce478e3f441b514773e36b1f0")
build() {
- cd "amalthea-v$pkgver"
+ cd "${PROJECT}-v$pkgver"
make DC=${DC} || return 1
}
package() {
- cd "amalthea-v$pkgver"
+ cd "${PROJECT}-v$pkgver"
make DESTDIR=$pkgdir install DC=${DC} || return 1
}
-