summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene 'Vindex' Stulin2022-09-15 23:15:00 +0300
committerEugene 'Vindex' Stulin2022-09-15 23:15:00 +0300
commitd0c43dc4f0f75c3bc614045103f25fe90b7a13c2 (patch)
tree0efa857ccbe82493e5d6c3af324f60be73b66528
downloadaur-d0c43dc4f0f75c3bc614045103f25fe90b7a13c2.tar.gz
Initial commit for the gdc-based version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa96b3d8ff7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = amalthea-ldc2
+ pkgdesc = Small general library for the D programming language, version for GDC
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://gitlab.com/os-18/amalthea
+ arch = x86_64
+ license = Boost or LGPL3
+ makedepends = make
+ makedepends = bash
+ makedepends = chrpath
+ makedepends = lsb-release
+ makedepends = glib2
+ depends = gcc-d
+ source = amalthea-gdc-1.2.1.tar.gz::https://gitlab.com/os-18/amalthea/-/archive/v1.2.1/amalthea-v1.2.1.tar.gz
+ sha256sums = e002fb21e8b2595bcd867eb6a9c5c2603633ca0403433b6aea0b3ea2b581fe67
+
+pkgname = amalthea-gdc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..593a45cda36d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Eugene 'Vindex' Stulin <tech.vindex@gmail.com>
+
+pkgname=amalthea-gdc
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Small general library for the D programming language, version for GDC"
+arch=('x86_64')
+url="https://gitlab.com/os-18/amalthea"
+license=('Boost or LGPL3')
+makedepends=('make' 'bash' 'chrpath' 'lsb-release' 'glib2')
+depends=('gcc-d')
+source=("$pkgname-$pkgver.tar.gz::$url/-/archive/v$pkgver/amalthea-v$pkgver.tar.gz")
+sha256sums=('e002fb21e8b2595bcd867eb6a9c5c2603633ca0403433b6aea0b3ea2b581fe67')
+
+build() {
+ cd "amalthea-v$pkgver"
+ make || return 1
+}
+
+package() {
+ GDC_VERSION=`gdc -dumpversion`
+ INCDIR=lib/gcc/x86_64-pc-linux-gnu/${GDC_VERSION}/include/d/
+ cd "amalthea-v$pkgver"
+ make DESTDIR=$pkgdir INCDIR=${INCDIR} install || return 1
+}
+