summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene 'Vindex' Stulin2021-10-06 01:37:03 +0300
committerEugene 'Vindex' Stulin2021-10-06 01:48:36 +0300
commited1359d2f8d9d5521d7c2a94fe2720475c92e012 (patch)
tree24f6c0c7c9917da253b6d5b0a5e29fc51dbbded6
downloadaur-ed1359d2f8d9d5521d7c2a94fe2720475c92e012.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a19896b5d113
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = amalthea-ldc2
+ pkgdesc = Small general library for the D programming language
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://gitlab.com/os-18/amalthea
+ arch = x86_64
+ license = LGPL3
+ makedepends = make
+ makedepends = bash
+ makedepends = chrpath
+ makedepends = lsb-release
+ makedepends = glib2
+ depends = ldc
+ source = amalthea-ldc2-1.0.1.tar.gz::https://gitlab.com/os-18/amalthea/-/archive/v1.0.1/amalthea-v1.0.1.tar.gz
+ sha256sums = a5996fa2415cc8ec1fc64ddb7b060686e8c526cf07d8b1c3aa7e83b812d589de
+
+pkgname = amalthea-ldc2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21d11fd5f785
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Eugene 'Vindex' Stulin <tech.vindex@gmail.com>
+
+pkgname=amalthea-ldc2
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Small general library for the D programming language"
+arch=('x86_64')
+url="https://gitlab.com/os-18/amalthea"
+license=('LGPL3')
+makedepends=('make' 'bash' 'chrpath' 'lsb-release' 'glib2')
+depends=('ldc')
+source=("$pkgname-$pkgver.tar.gz::$url/-/archive/v$pkgver/amalthea-v$pkgver.tar.gz")
+sha256sums=('a5996fa2415cc8ec1fc64ddb7b060686e8c526cf07d8b1c3aa7e83b812d589de')
+
+build() {
+ cd "amalthea-v$pkgver"
+ make || return 1
+}
+
+package() {
+ # cd "${pkgname}-${pkgver}"
+ cd "amalthea-v$pkgver"
+ make DESTDIR=$pkgdir INCDIR=include/dlang/ldc install || return 1
+}
+