summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElrondo462017-11-19 16:57:34 +0100
committerElrondo462017-11-19 16:57:34 +0100
commit4c9044d2c463b015d1ce2309fdeba14644a5bdb3 (patch)
treeef4c2f9ddb105edf96d2353772e1c351d61e094d
parent0e27f65fdef9bd16b0f48321323c2eb7fac79da9 (diff)
downloadaur-4c9044d2c463b015d1ce2309fdeba14644a5bdb3.tar.gz
Thanks to Pepito from TnV bug solved version to 1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--amar.py16
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3e4219a7b1f..fd43732234bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = amar-installer
pkgdesc = Install AMAR repository
- pkgver = 1.0
- pkgrel = 2
+ pkgver = 1.1
+ pkgrel = 1
url = https://www.tuxnvape.fr/
arch = x86_64
license = GPL3
@@ -12,7 +12,7 @@ pkgbase = amar-installer
source = amar.png
source = amar.desktop
sha256sums = 2032a352c85fc9945bc0b3cb7fd5cde97b7eeb239cc2235e8fa3585029fe2af0
- sha256sums = 874700067f446dff59f8e4e6c3b14519ca8afdf31742af629343c80002c71376
+ sha256sums = 7d55246c919c9e22f7cfdb0ba0b92a3e13dc87ca0414777cbece4c24c3380cd1
sha256sums = 0f2f75e7aaf1375b14570067563330f438e2a20158642b76c16a4ff4a8bb3158
pkgname = amar-installer
diff --git a/PKGBUILD b/PKGBUILD
index c4fd6e5fa80b..f8fb305aea5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Elrondo46 TuxnVape <elrond94@hotmail.com>
pkgname=amar-installer
-pkgver=1.0
-pkgrel=2
+pkgver=1.1
+pkgrel=1
pkgdesc="Install AMAR repository"
arch=('x86_64')
license=('GPL3')
@@ -11,7 +11,7 @@ depends=('gksu' 'tk' 'python-pillow')
source=("amar.py"
"amar.png"
"amar.desktop")
-sha256sums=('2032a352c85fc9945bc0b3cb7fd5cde97b7eeb239cc2235e8fa3585029fe2af0'
+sha256sums=('7d55246c919c9e22f7cfdb0ba0b92a3e13dc87ca0414777cbece4c24c3380cd1'
'874700067f446dff59f8e4e6c3b14519ca8afdf31742af629343c80002c71376'
'0f2f75e7aaf1375b14570067563330f438e2a20158642b76c16a4ff4a8bb3158')
diff --git a/amar.py b/amar.py
index e13d5e20fe4e..c2d797fc5045 100644
--- a/amar.py
+++ b/amar.py
@@ -2,15 +2,16 @@
# coding: utf-8
"""
Projet AMAR
-Remerciements : Baba, Fredo, Rhylx, Francky, hRF...
-Date : 14 Oct 2K17
-version : b2
+Remerciements : Baba, Fredo, Rhylx, Francky, hRF, Pepito...
+Date : 14 Oct 2K17,
+ 1.0.1 : 19 Nov 2017
+version : 1.0.1
gksudo -s python amar.py
"""
import os
import sys
-from PIL import Image #importation des modules nécessaires
+from PIL import Image
import subprocess
from tkinter import *
@@ -27,9 +28,12 @@ if os.getuid() != 0:
pacmanfichier = "/etc/pacman.conf"
try:
+ #On suppose d'abord qu'AMAR est désactivé. On met donc etatamar = 0 au départ.
+ etatamar = 0
with open(pacmanfichier, 'r') as searchfile:
for line in searchfile:
- if 'amar' in line:
+ #Si la chaîne '[AMAR]' est écrit quelque part dans pacman.conf, alors le dépôt est activé et on met etatamar = 1.
+ if '[AMAR]' in line:
etatamar = 1
searchfile.close()
except OSError:
@@ -37,8 +41,6 @@ except OSError:
sys.exit(1)
configamar = "\n#Do not disable AMAR manually if you use the app\n[AMAR]\nSigLevel = Never\nServer = https://amar.lagout.org/x86_64/\n"
-etatamar = 0
-
def pressA():
A.config(state=DISABLED)