summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-11-09 12:10:35 -0500
committerfrealgagu2018-11-09 12:10:35 -0500
commit0ab91a2512d59ba77a9c97f44ac2047a09469f24 (patch)
treedf7774256914585cedd09596251e71e1862b0c3b
parentc0d48ae1b0a0c86a91655065501f5b564c6bdeee (diff)
downloadaur-0ab91a2512d59ba77a9c97f44ac2047a09469f24.tar.gz
Adding libssh-gnutls dependency to fix bug at start.
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
-rw-r--r--amarok.install8
4 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c610fccac07b..1fbd73cd81a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = amarok
pkgdesc = The powerful music player for KDE
- pkgver = 2.9.0.r258.f632617d29
+ pkgver = 2.9.0.r259.a3971e4d47
pkgrel = 1
url = http://amarok.kde.org/
arch = x86_64
+ license = FDL
license = GPL2
license = LGPL2.1
- license = FDL
makedepends = extra-cmake-modules
makedepends = gdk-pixbuf2
makedepends = git
@@ -25,6 +25,7 @@ pkgbase = amarok
depends = libmtp
depends = libmygpo-qt5
depends = libofa
+ depends = libssh-gnutls
depends = mariadb
depends = phonon-qt5
depends = qt5-webengine
@@ -32,7 +33,7 @@ pkgbase = amarok
depends = threadweaver
optdepends = ifuse: support for Apple iPod Touch and iPhone
optdepends = loudmouth: backend needed by mp3tunes for syncing
- source = git://git.kde.org/amarok.git#commit=f632617d29a2e95b9c01f8d26a734a3ff23de212
+ source = git://git.kde.org/amarok.git#commit=a3971e4d47435adb30306e4428cf7ad7b90339c0
validpgpkeys = D81C0CB38EB725EF6691C385BB463350D6EF31EF
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 557fe138db6a..6a14ee35aaf4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
amarok-*.tar.xz
+amarok-*.log
+PKGBUILD-namcap.log
amarok/
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index ca305e7a55a4..c4953676b825 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,21 @@
# Contributor: damir <damir@archlinux.org>
pkgname=amarok
-pkgver=2.9.0.r258.f632617d29
-_commit=f632617d29a2e95b9c01f8d26a734a3ff23de212
+pkgver=2.9.0.r259.a3971e4d47
pkgrel=1
pkgdesc="The powerful music player for KDE"
-arch=(x86_64)
+arch=("x86_64")
url="http://amarok.kde.org/"
-license=("GPL2" "LGPL2.1" "FDL")
-depends=("kcmutils" "kdnssd" "kirigami2" "knewstuff" "ktexteditor" "libgpod" "liblastfm-qt5" "libmtp" "libmygpo-qt5" "libofa" "mariadb" "phonon-qt5" "qt5-webengine" "taglib-extras" "threadweaver")
+license=("FDL" "GPL2" "LGPL2.1")
+depends=("kcmutils" "kdnssd" "kirigami2" "knewstuff" "ktexteditor" "libgpod" "liblastfm-qt5" "libmtp" "libmygpo-qt5" "libofa" "libssh-gnutls" "mariadb" "phonon-qt5" "qt5-webengine" "taglib-extras" "threadweaver")
makedepends=("extra-cmake-modules" "gdk-pixbuf2" "git" "knotifyconfig" "libgpod" "libmtp" "libmygpo-qt5" "loudmouth")
optdepends=("ifuse: support for Apple iPod Touch and iPhone"
"loudmouth: backend needed by mp3tunes for syncing")
+_commit=a3971e4d47435adb30306e4428cf7ad7b90339c0
#source=("http://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
source=("git://git.kde.org/amarok.git#commit=$_commit")
-sha256sums=('SKIP')
+
+sha256sums=("SKIP")
validpgpkeys=("D81C0CB38EB725EF6691C385BB463350D6EF31EF") # Heiko Becker <heirecka@exherbo.org>
prepare() {
@@ -36,5 +37,5 @@ build() {
package() {
cd "${srcdir}/build"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="${pkgdir}" install
}
diff --git a/amarok.install b/amarok.install
index 81ce5c4b01cf..5c501dc49916 100644
--- a/amarok.install
+++ b/amarok.install
@@ -1,12 +1,12 @@
post_install() {
- xdg-icon-resource forceupdate --theme hicolor &> /dev/null
- update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
}
post_upgrade() {
- post_install
+ post_install
}
post_remove() {
- post_install
+ post_install
}