summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredy García2018-09-08 21:51:45 -0500
committerFredy García2018-09-08 21:51:45 -0500
commitd9ce3471f6b3a1f0c42e067bf1fa1bb07ae06ef2 (patch)
treed08c41f06f2bb74e841f24936fba0c896a4a2fa1
parent39a48b0997c9a7f1854af2dd8f4e4b0c4b9896ba (diff)
downloadaur-d9ce3471f6b3a1f0c42e067bf1fa1bb07ae06ef2.tar.gz
Using last git version in order to use QT5
-rw-r--r--.SRCINFO38
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
3 files changed, 47 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a83e2c6892..8be3859b538 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,38 @@
pkgbase = amarok
pkgdesc = The powerful music player for KDE
- pkgver = 2.9.0
- pkgrel = 2
+ pkgver = 2.9.0.r245.68a1f0ecdd
+ pkgrel = 1
url = http://amarok.kde.org/
arch = x86_64
license = GPL2
license = LGPL2.1
license = FDL
- makedepends = automoc4
- makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = gdk-pixbuf2
+ makedepends = git
+ makedepends = knotifyconfig
makedepends = libgpod
makedepends = libmtp
+ makedepends = libmygpo-qt5
makedepends = loudmouth
- makedepends = libmygpo-qt
- makedepends = qca-qt4
- depends = kdebase-runtime
+ depends = kcmutils
+ depends = kdnssd
+ depends = kirigami2
+ depends = knewstuff
+ depends = ktexteditor
+ depends = liblastfm-qt5
+ depends = libofa
depends = mariadb
+ depends = qt5-webengine
depends = taglib-extras
- depends = liblastfm
- depends = ffmpeg
- depends = libofa
- depends = qjson
- depends = qtscriptgenerator
+ depends = threadweaver
+ optdepends = ifuse: support for Apple iPod Touch and iPhone
optdepends = libgpod: support for Apple iPod audio devices
optdepends = libmtp: support for portable media devices
+ optdepends = libmygpo-qt5: gpodder.net Internet Service
optdepends = loudmouth: backend needed by mp3tunes for syncing
- optdepends = ifuse: support for Apple iPod Touch and iPhone
- optdepends = libmygpo-qt: gpodder.net Internet Service
- optdepends = gst-libav: MP3 codecs
- optdepends = qca-qt4: Ampache support
- source = http://download.kde.org/stable/amarok/2.9.0/src/amarok-2.9.0.tar.xz
- source = http://download.kde.org/stable/amarok/2.9.0/src/amarok-2.9.0.tar.xz.sig
+ source = git://git.kde.org/amarok.git#commit=68a1f0ecdd16d2d85bfad0963a3abf98b486547d
validpgpkeys = D81C0CB38EB725EF6691C385BB463350D6EF31EF
- sha256sums = e3678de79db36956bc8588b9905726ace1b9188e7fdf89eaea265f1cb03116fd
sha256sums = SKIP
pkgname = amarok
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 00000000000..557fe138db6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+amarok-*.tar.xz
+amarok/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 317b663092b..7ce52afd1ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,43 @@
-# $Id$
-# Maintainer: Ronald van Haren <ronald@archlinux.org>
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Maintainer: Fredy García <frealgagu at gmail dot com>
+# Contributor: Ronald van Haren <ronald@archlinux.org>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: damir <damir@archlinux.org>
pkgname=amarok
-pkgver=2.9.0
-pkgrel=2
+pkgver=2.9.0.r245.68a1f0ecdd
+_commit=68a1f0ecdd16d2d85bfad0963a3abf98b486547d
+pkgrel=1
pkgdesc="The powerful music player for KDE"
arch=(x86_64)
url="http://amarok.kde.org/"
-license=(GPL2 LGPL2.1 FDL)
-depends=(kdebase-runtime mariadb taglib-extras liblastfm ffmpeg libofa qjson qtscriptgenerator)
-makedepends=('automoc4' 'cmake' 'libgpod' 'libmtp' 'loudmouth' 'libmygpo-qt' 'qca-qt4')
-optdepends=('libgpod: support for Apple iPod audio devices'
- 'libmtp: support for portable media devices'
- 'loudmouth: backend needed by mp3tunes for syncing'
- 'ifuse: support for Apple iPod Touch and iPhone'
- 'libmygpo-qt: gpodder.net Internet Service'
- 'gst-libav: MP3 codecs'
- 'qca-qt4: Ampache support')
-source=("http://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
-sha256sums=('e3678de79db36956bc8588b9905726ace1b9188e7fdf89eaea265f1cb03116fd'
- 'SKIP')
-validpgpkeys=(D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heirecka@exherbo.org>
+license=("GPL2" "LGPL2.1" "FDL")
+depends=("kcmutils" "kdnssd" "kirigami2" "knewstuff" "ktexteditor" "liblastfm-qt5" "libofa" "mariadb" "qt5-webengine" "taglib-extras" "threadweaver")
+makedepends=("extra-cmake-modules" "gdk-pixbuf2" "git" "knotifyconfig" "libgpod" "libmtp" "libmygpo-qt5" "loudmouth")
+optdepends=("ifuse: support for Apple iPod Touch and iPhone"
+ "libgpod: support for Apple iPod audio devices"
+ "libmtp: support for portable media devices"
+ "libmygpo-qt5: gpodder.net Internet Service"
+ "loudmouth: backend needed by mp3tunes for syncing")
+#source=("http://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
+source=("git://git.kde.org/amarok.git#commit=$_commit")
+sha256sums=("SKIP")
+validpgpkeys=("D81C0CB38EB725EF6691C385BB463350D6EF31EF") # Heiko Becker <heirecka@exherbo.org>
prepare() {
- mkdir -p build
+ mkdir -p "${srcdir}/build"
}
build() {
- cd build
- cmake ../$pkgname-$pkgver \
- -DKDE4_BUILD_TESTS=OFF \
+ cd "${srcdir}/build"
+ cmake "../${pkgname}" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DWITH_NepomukCore=OFF \
- -DWITH_Soprano=OFF \
- -DWITH_QTWEBKIT=OFF
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=OFF
make
}
package() {
- cd build
+ cd "${srcdir}/build"
make DESTDIR="$pkgdir" install
}