summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevorster2016-06-01 17:21:34 +0200
committerevorster2016-06-01 17:21:34 +0200
commit9605501cecae5b54cbc4dee6f5e25a62b34b2df2 (patch)
tree85afa7664f09e704889474712a262f479c972141
parentcd180e034d53d5fb72f90ca948e60d059d6047c5 (diff)
downloadaur-9605501cecae5b54cbc4dee6f5e25a62b34b2df2.tar.gz
fix compilation with gcc6. Unfortunately we now need a patch until the git repo is updated
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--amarok-git.patch20
3 files changed, 33 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d3e0b324f8d..ef6b686ffc9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = amarok-git
pkgdesc = The powerful music player for KDE - GIT version
- pkgver = v2.8.90.14.g048ca3d
+ pkgver = v2.8.90.16.ga5df287
pkgrel = 1
url = http://amarok.kde.org
install = amarok-git.install
@@ -39,7 +39,7 @@ pkgbase = amarok-git
conflicts = amarok2
replaces = amarok-svn
replaces = amarok2-svn
- source = amarok-git::git://anongit.kde.org/amarok.git
+ source = git://anongit.kde.org/amarok.git
sha1sums = SKIP
pkgname = amarok-git
diff --git a/PKGBUILD b/PKGBUILD
index 7d46e079e263..3572fea9ea62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Maƫl Kerbiriou <mael.kerbiriou-at-free-dot-fr>
pkgname=amarok-git
-pkgver=v2.8.90.14.g048ca3d
+pkgver=v2.8.90.16.ga5df287
pkgrel=1
pkgdesc="The powerful music player for KDE - GIT version"
arch=("i686" "x86_64")
@@ -22,20 +22,27 @@ conflicts=('amarok' 'amarok2')
provides=('amarok')
replaces=('amarok-svn' 'amarok2-svn')
install="${pkgname}.install"
-source=(${pkgname}::git://anongit.kde.org/amarok.git)
+#source=(${pkgname}::git://anongit.kde.org/amarok.git)
+source=(git://anongit.kde.org/amarok.git)
sha1sums=('SKIP')
pkgver() {
- cd "${pkgname}"
+ cd amarok
git describe --always | sed 's|-|.|g'
}
+prepare(){
+#cd amarok
+pwd;
+patch -Np1 <../amarok-git.patch
+}
+
build() {
rm -rf build
mkdir -p build
cd build
export PKG_CONFIG_PATH="/usr/lib/ffmpeg2.8/pkgconfig"
- cmake "../${pkgname}" -Wno-dev \
+ cmake "../amarok" -Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DKDE4_BUILD_TESTS=OFF \
diff --git a/amarok-git.patch b/amarok-git.patch
new file mode 100644
index 000000000000..ff87e05aff93
--- /dev/null
+++ b/amarok-git.patch
@@ -0,0 +1,20 @@
+--- src/amarok/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp 2013-08-14 22:22:52.000000000 +0200
++++ src/amarok/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp 2016-05-25 14:43:13.681557351 +0200
+@@ -28,6 +28,7 @@
+ #include "playlist/PlaylistModelStack.h"
+
+ using namespace Playlists;
++using namespace Playlist;
+
+ XSPFPlaylist::XSPFPlaylist( const KUrl &url, Playlists::PlaylistProvider *provider, OnLoadAction onLoad )
+ : PlaylistFile( url, provider )
+@@ -101,7 +102,7 @@
+ //FIXME: this needs to be moved to whatever is creating the XSPFPlaylist
+ if( m_autoAppendAfterLoad )
+ The::playlistController()->insertPlaylist(
+- ::Playlist::ModelStack::instance()->bottom()->rowCount(),
++ ModelStack::instance()->bottom()->rowCount(),
+ Playlists::PlaylistPtr( this )
+ );
+ }
+