summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Placidina Maria2022-10-06 13:22:25 -0300
committerAlan Placidina Maria2022-10-06 13:22:25 -0300
commitd19194d0c951c2aac00bfe3cd57881c95c402bca (patch)
tree517281c664e82b50f8e151445dc5730d74710e2a
downloadaur-d19194d0c951c2aac00bfe3cd57881c95c402bca.tar.gz
feature(repository): create amass-bin
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..beb0fa54e330
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = amass-bin
+ pkgdesc = In-depth Attack Surface Mapping and Asset Discovery
+ pkgver = 3.20.0
+ pkgrel = 1
+ url = https://github.com/OWASP/Amass
+ arch = x86_64
+ license = Apache
+ conflicts = amass
+ source = https://github.com/OWASP/Amass/releases/download/v3.20.0/amass_linux_amd64.zip
+ sha512sums = fffd310a5077be4d02ebfa3092a139b31b8b665cd0359af90f3ed9ff242ac3567eab7c82e965201974c8a6ba8b4c82e43a34e66f7c5e68d11d11d174573b1e97
+
+pkgname = amass-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..18a32032bb2e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zip
+*.tar.zst
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eeb88952edfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alan Placidina Maria <placidina[at]protonmail[dot]com>
+
+_pkgname=amass
+pkgname=${_pkgname}-bin
+pkgver=3.20.0
+pkgrel=1
+pkgdesc="In-depth Attack Surface Mapping and Asset Discovery"
+arch=('x86_64')
+url="https://github.com/OWASP/Amass"
+license=('Apache')
+conflicts=('amass')
+source=(https://github.com/OWASP/Amass/releases/download/v${pkgver}/${_pkgname}_linux_amd64.zip)
+sha512sums=('fffd310a5077be4d02ebfa3092a139b31b8b665cd0359af90f3ed9ff242ac3567eab7c82e965201974c8a6ba8b4c82e43a34e66f7c5e68d11d11d174573b1e97')
+
+package() {
+ cd "${_pkgname}_linux_amd64"
+
+ install -dm 755 "${pkgdir}/usr/share/${_pkgname}"
+ install -Dm 755 ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+
+ cp -a --no-preserve=ownership "examples/" "${pkgdir}/usr/share/${_pkgname}"
+ find "${pkgdir}/usr/share/${_pkgname}/examples" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/usr/share/${_pkgname}/examples" -type f -exec chmod 644 {} \;
+}