summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrzee2021-08-03 10:31:00 +0000
committerdrzee2021-08-03 10:31:00 +0000
commite93780a54a7e93414d26b0c9cf961e6ab37f4e82 (patch)
treec2b50b9cee852a9fac955b849ecf6f5466d804ce
downloadaur-e93780a54a7e93414d26b0c9cf961e6ab37f4e82.tar.gz
PKGBUILD to install version 3.1.90.0 of AWS Systems Manager Agent
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3f15e166803
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = amazon-ssm-agent-bin
+ pkgdesc = Amazon SSM Agent for managing EC2 Instances using the SSM APIs.
+ pkgver = 3.1.90.0
+ pkgrel = 1
+ url = https://aws.amazon.com/documentation/systems-manager/
+ arch = x86_64
+ license = APACHE
+ depends = glibc
+ provides = amazon-ssm-agent
+ conflicts = amazon-ssm-agent
+ source = https://s3.amazonaws.com/ec2-downloads-windows/SSMAgent/3.1.90.0/debian_amd64/amazon-ssm-agent.deb
+ md5sums = d5a6e25a92430d19cdef208e229e6e60
+
+pkgname = amazon-ssm-agent-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65637d9fa82f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: drzee <info@drzee.net>
+pkgname=amazon-ssm-agent-bin
+pkgver=3.1.90.0
+pkgrel=1
+pkgdesc="Amazon SSM Agent for managing EC2 Instances using the SSM APIs."
+arch=('x86_64')
+url="https://aws.amazon.com/documentation/systems-manager/"
+license=('APACHE')
+groups=()
+depends=('glibc')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=(https://s3.amazonaws.com/ec2-downloads-windows/SSMAgent/3.1.90.0/debian_amd64/amazon-ssm-agent.deb)
+md5sums=('d5a6e25a92430d19cdef208e229e6e60')
+noextract=()
+
+prepare() {
+ cd "$srcdir"
+ tar -xf data.tar.gz
+
+}
+
+
+package() {
+ cd "$srcdir"
+
+ install -dm755 "$pkgdir"/usr/
+ cp -R "${srcdir}"/usr/ "${pkgdir}"
+
+ install -dm755 "$pkgdir"/etc/amazon/
+ cp -R "${srcdir}"/etc/amazon/ "${pkgdir}/etc/"
+
+ install -Dm644 \
+ "$srcdir"/lib/systemd/system/amazon-ssm-agent.service \
+ "$pkgdir"/usr/lib/systemd/system/amazon-ssm-agent.service
+
+}
+