summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbl00dy18372020-12-13 22:09:28 +0100
committerbl00dy18372020-12-13 22:09:28 +0100
commit4bce8cc3e17f4d83f92ed03cae23439b07d6bffd (patch)
tree04a06b6bc2cda26c8a97a1803d882d93ff1eadd6
downloadaur-4bce8cc3e17f4d83f92ed03cae23439b07d6bffd.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a90106fae20a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = amb-svn
+ pkgdesc = AMB stands for Ancient Machines Book. It is an extremely lightweight file format meant to store any kind of hypertext documentation
+ pkgver = r119
+ pkgrel = 1
+ url = http://ambook.sourceforge.net/
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = subversion
+ makedepends = tar
+ makedepends = make
+ makedepends = gcc
+ makedepends = sed
+ conflicts = amb
+ source = svn+https://svn.code.sf.net/p/ambook/code/amb/trunk
+ sha512sums = SKIP
+
+pkgname = amb-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c41793cb7b45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+_pkgname=amb
+pkgname=${_pkgname}-svn
+pkgver=r119
+pkgrel=1
+pkgdesc='AMB stands for Ancient Machines Book. It is an extremely lightweight file format meant to store any kind of hypertext documentation '
+url='http://ambook.sourceforge.net/'
+license=('MIT')
+arch=('x86_64' 'aarch64')
+conflicts=(${_pkgname})
+makedepends=('subversion' 'tar' 'make' 'gcc' 'sed')
+source=("svn+https://svn.code.sf.net/p/ambook/code/${_pkgname}/trunk")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/trunk"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+prepare() {
+ cd ${srcdir}"/trunk/"
+ sed -n '/.*LICENSE.*/,$p' ${_pkgname}.txt > LICENSE
+}
+
+build() {
+ cd ${srcdir}"/trunk/"
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin/"
+ cd ${srcdir}"/trunk/"
+ mv ${_pkgname} ${pkgdir}/usr/bin/
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}