summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVir Chaudhury2021-04-06 21:22:29 +0800
committerVir Chaudhury2021-04-06 21:22:29 +0800
commit042c42b23f840fffe3ad648e5d45aa0aa9c5c5ff (patch)
treeb08fbddc9bc971f5813241a8008d8522846f9d7f
downloadaur-ambit-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD36
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbb900e2abeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ambit-git
+ pkgdesc = Dotfile manager written in Rust.
+ pkgver = 0.1.0.r75.g897e5cf
+ pkgrel = 1
+ url = https://github.com/plamorg/ambit
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL3
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ provides = ambit
+ conflicts = ambit-bin
+ options = strip
+ source = ambit::git+https://github.com/plamorg/ambit.git
+ sha256sums = SKIP
+
+pkgname = ambit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7e5b217d034
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Vir Chaudhury <virchau13@mail.hexular.net>
+# Maintainer: Edward Wibowo <wibow9770@gmail.com>
+pkgname=ambit-git
+_pkgname="ambit"
+pkgver=0.1.0.r75.g897e5cf
+pkgrel=1
+pkgdesc="Dotfile manager written in Rust."
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/plamorg/ambit"
+license=('GPL3')
+makedepends=('rust' 'cargo' 'git')
+provides=("ambit")
+conflicts=("ambit-bin")
+options=("strip")
+source=("$_pkgname::git+https://github.com/plamorg/ambit.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "%s\n" "$(grep '^version =' Cargo.toml | head -n1 | cut -d\" -f2).r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ env CARGO_INCREMENTAL=0 cargo build --release --locked
+}
+
+check() {
+ cd "$_pkgname"
+ env CARGO_INCREMENTAL=0 cargo test --release
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 "target/release/ambit" -t "$pkgdir/usr/bin/"
+}