summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbl00dy18372020-12-13 22:11:40 +0100
committerbl00dy18372020-12-13 22:11:40 +0100
commit73114bbafc2a34c8978a06ac779ed512951b59ae (patch)
treed7abeb400cd01d91fee933bf465cd1078621107d
downloadaur-73114bbafc2a34c8978a06ac779ed512951b59ae.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0db32261a65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ambpack-svn
+ pkgdesc = AMB stands for Ancient Machines Book. It is an extremely lightweight file format meant to store any kind of hypertext documentation
+ pkgver = r119
+ pkgrel = 1
+ url = http://ambook.sourceforge.net/
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = subversion
+ makedepends = tar
+ makedepends = make
+ makedepends = gcc
+ makedepends = sed
+ conflicts = ambpack
+ source = svn+https://svn.code.sf.net/p/ambook/code/ambpack/trunk
+ sha512sums = SKIP
+
+pkgname = ambpack-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b73802eb347
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+_pkgname=ambpack
+pkgname=${_pkgname}-svn
+pkgver=r119
+pkgrel=1
+pkgdesc='AMB stands for Ancient Machines Book. It is an extremely lightweight file format meant to store any kind of hypertext documentation '
+url='http://ambook.sourceforge.net/'
+license=('MIT')
+arch=('x86_64' 'aarch64')
+conflicts=(${_pkgname})
+makedepends=('subversion' 'tar' 'make' 'gcc' 'sed')
+source=("svn+https://svn.code.sf.net/p/ambook/code/${_pkgname}/trunk")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/trunk"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+prepare() {
+ cd ${srcdir}"/trunk/"
+ sed -n '/.*LICENSE.*/,$p' ${_pkgname}.txt > LICENSE
+}
+
+build() {
+ cd ${srcdir}"/trunk/"
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin/"
+ cd ${srcdir}"/trunk/"
+ mv ${_pkgname} ${pkgdir}/usr/bin/
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}