aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfreylint2021-07-05 14:14:02 -0500
committerfreylint2021-07-05 14:14:02 -0500
commita434eff0a8cadc8acfe9bcf4491e0092248058f8 (patch)
tree90ffcfdd6dc1111ab63157c156e9c22eb4f57411
downloadaur-a434eff0a8cadc8acfe9bcf4491e0092248058f8.tar.gz
Initial project files
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD31
-rw-r--r--README.md2
5 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3b4910d2c82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ambuild-git
+ pkgdesc = Allied Modders build system for sourcepawn and sourcemode extensions.
+ pkgver = 2.2.r8.g6ad11a1
+ pkgrel = 2.2
+ url = https://github.com/freylint/ambuild-aur
+ arch = i386
+ arch = x86_64
+ license = BSD-3-Clause
+ makedepends = python-setuptools
+ depends = python3
+ depends = gcc
+ depends = clang
+ provides = ambuild
+ provides = ambuild2
+ replaces = ambuild
+ replaces = ambuild2
+ source = ambuild-git::git+https://github.com/alliedmodders/ambuild.git
+ sha256sums = SKIP
+
+pkgname = ambuild-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..09257e56ca4a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Packge Sources
+pkg/
+src/
+ambuild-git/
+
+# Built package files
+*.tar.*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a37d3847afed
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+BSD 3-Clause License
+
+Copyright (c) 2021, Frey
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+3. Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e12d3f4d967
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Katherine Vance <katvance64@gmail.com>
+# :vim
+pkgname=ambuild-git
+pkgver=2.2.r8.g6ad11a1
+pkgrel=2.2
+pkgdesc="Allied Modders build system for sourcepawn and sourcemode extensions."
+arch=("i386" "x86_64")
+url="https://github.com/freylint/ambuild-aur"
+license=('BSD-3-Clause')
+depends=("python3" "gcc" "clang")
+makedepends=("python-setuptools")
+sha256sums=('SKIP')
+
+provides=("ambuild" "ambuild2")
+replaces=("ambuild" "ambuild2")
+source=("$pkgname::git+https://github.com/alliedmodders/ambuild.git")
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build () {
+ cd "$pkgname"
+ python3 setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..5636ead3a4a8
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# ambuild-aur
+PKGBUILD for the ambuild-git aur package.