summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen2015-06-09 16:07:20 +0800
committerAllen2015-06-09 16:07:20 +0800
commitd6ae869d1a1b1f00243cf29747cbed961a7f4e98 (patch)
tree2ba6e0f656871af0680b9ccc8a984f92aee4e9cb
downloadaur-d6ae869d1a1b1f00243cf29747cbed961a7f4e98.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc44a71ff31f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = amd
+ pkgdesc = An Automated Motif Discovery Tool Using Stepwise Refinement of Gapped Consensuses
+ pkgver = 1.0.0
+ pkgrel = 3
+ url = http://www.plosone.org/article/info%3Adoi%2F10.1371%2Fjournal.pone.0024576
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = unrar
+ noextract = journal.pone.0024576.s004.rar
+ options = !strip
+ options = !buildflags
+ source = journal.pone.0024576.s004.rar::http://www.plosone.org/article/fetchSingleRepresentation.action?uri=info:doi/10.1371/journal.pone.0024576.s004
+ md5sums = 18eb715f0fb1f8bbfc1b1c359f04e77a
+
+pkgname = amd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..40b0e6ebe671
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+#Maintainer: allencch <allencch at hotmail dot com>
+pkgname=amd
+pkgver=1.0.0
+pkgrel=3
+pkgdesc="An Automated Motif Discovery Tool Using Stepwise Refinement of Gapped Consensuses"
+arch=('i686' 'x86_64')
+url="http://www.plosone.org/article/info%3Adoi%2F10.1371%2Fjournal.pone.0024576"
+license=('custom')
+makedepends=("unrar")
+source=("journal.pone.0024576.s004.rar::http://www.plosone.org/article/fetchSingleRepresentation.action?uri=info:doi/10.1371/journal.pone.0024576.s004")
+md5sums=('18eb715f0fb1f8bbfc1b1c359f04e77a')
+noextract=("journal.pone.0024576.s004.rar")
+options=(!strip !buildflags)
+
+build() {
+ #mv journal.pone.0024576.s004 journal.pone.0024576.s004.rar
+ unrar x -y "journal.pone.0024576.s004.rar"
+ cd "${srcdir}/source"
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cd "${srcdir}/source"
+ install -m755 AMD "${pkgdir}/usr/bin"
+}