summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2022-10-18 20:29:29 -0700
committerpyamsoft2022-10-18 20:29:29 -0700
commit22d3b536f79cfae70a27d6831b2d9dcca0f702ed (patch)
tree9c0bdc18dcba8aafd1db6123b0e4f674fc5e3df1
downloadaur-22d3b536f79cfae70a27d6831b2d9dcca0f702ed.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD66
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e4e28119595
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = amd-disable-c6-git
+ pkgdesc = Automatically disable the C6 power saving state on AMD Zen (Ryzen / Epyc) processors
+ pkgver = r13.4eb03b5
+ pkgrel = 1
+ url = https://github.com/joakimkistowski/amd-disable-c6.git
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ provides = amd-disable-c6
+ provides = disable-c6-systemd
+ conflicts = amd-disable-c6
+ conflicts = disable-c6-systemd
+ source = amd-disable-c6::git+https://github.com/joakimkistowski/amd-disable-c6.git#branch=master
+ sha256sums = SKIP
+
+pkgname = amd-disable-c6-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fa57af028d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+##
+# Maintainer: pyamsoft <developer(dot)pyamsoft(at)gmail(dot)com>
+##
+
+_gitname=amd-disable-c6
+# shellcheck disable=SC2034
+pkgname=amd-disable-c6-git
+# shellcheck disable=SC2034
+pkgdesc="Automatically disable the C6 power saving state on AMD Zen (Ryzen / Epyc) processors"
+# shellcheck disable=SC2034
+pkgver=r13.4eb03b5
+# shellcheck disable=SC2034
+pkgrel=1
+# shellcheck disable=SC2034
+arch=('i686' 'x86_64')
+# shellcheck disable=SC2034
+makedepends=('git')
+# shellcheck disable=SC2034
+depends=()
+# shellcheck disable=SC2034
+optdepends=()
+# shellcheck disable=SC2034
+provides=('amd-disable-c6' 'disable-c6-systemd')
+# shellcheck disable=SC2034
+conflicts=('amd-disable-c6' 'disable-c6-systemd')
+# shellcheck disable=SC2034
+license=('MIT')
+url="https://github.com/joakimkistowski/amd-disable-c6.git"
+
+##
+# The SHA256 is constantly changing since this is
+# pulled from git so skip the verification check
+##
+# shellcheck disable=SC2034
+source=("${_gitname}::git+${url}#branch=master")
+# shellcheck disable=SC2034
+sha256sums=('SKIP')
+
+pkgver() {
+ # shellcheck disable=SC2154
+ cd "${srcdir}/${_gitname}" || {
+ msg "Failed to cd into ${srcdir}/${_gitname}"
+ return 1
+ }
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ # shellcheck disable=SC2154
+ cd "${srcdir}/${_gitname}" || {
+ msg "Failed to cd into ${srcdir}/${_gitname}"
+ return 1
+ }
+}
+
+package() {
+ # shellcheck disable=SC2154
+ cd "${srcdir}/${_gitname}" || {
+ msg "Failed to cd into ${srcdir}/${_gitname}"
+ return 1
+ }
+
+ # shellcheck disable=SC2154
+ make DESTDIR="${pkgdir}" install
+}