diff options
author | pyamsoft | 2022-11-28 10:19:14 -0800 |
---|---|---|
committer | pyamsoft | 2022-11-28 10:24:18 -0800 |
commit | 28926375c36017cef93f517738d6ba8059be5078 (patch) | |
tree | 08321faee5b3b8cc34d490b0fa0b49db0eb2d01e | |
parent | a2ac4cec9ebedb8602958321b171da99e354ae03 (diff) | |
download | aur-28926375c36017cef93f517738d6ba8059be5078.tar.gz |
Patch service file to run on other targets too
Ensures the C6 state is still correctly disabled
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | 02-fix-service.patch | 18 | ||||
-rw-r--r-- | PKGBUILD | 8 |
3 files changed, 26 insertions, 4 deletions
@@ -1,7 +1,7 @@ pkgbase = amd-disable-c6-git pkgdesc = Automatically disable the C6 power saving state on AMD Zen (Ryzen / Epyc) processors pkgver = r13.4eb03b5 - pkgrel = 1 + pkgrel = 2 url = https://github.com/joakimkistowski/amd-disable-c6.git arch = i686 arch = x86_64 @@ -14,8 +14,10 @@ pkgbase = amd-disable-c6-git source = amd-disable-c6::git+https://github.com/joakimkistowski/amd-disable-c6.git#branch=master source = 00-fix-sbin.patch source = 01-fix-sbin.patch + source = 02-fix-service.patch sha256sums = SKIP sha256sums = c1bb428d02994f872e4be2f282ffd5c453f4ebc714a79fc8337032d9d02c1a4a sha256sums = 7dfa4a9b54df1cddfc2351d58768e848c07cac6eb8021fa6bd4eb812b9bfcd28 + sha256sums = 6f7772c801c57d083c2058f3899422531892ef4e89321f8f7455924418a1e5e6 pkgname = amd-disable-c6-git diff --git a/02-fix-service.patch b/02-fix-service.patch new file mode 100644 index 000000000000..c52b71b79686 --- /dev/null +++ b/02-fix-service.patch @@ -0,0 +1,18 @@ +--- a/amd-disable-c6.service 2022-11-28 10:15:36.267656056 -0800 ++++ b/amd-disable-c6.service 2022-11-27 20:58:51.000000000 -0800 +@@ -1,12 +1,10 @@ + [Unit] + Description=Service to disable the C6 State on AMD Zen-based (Ryzen, Epyc) processors on boot +-DefaultDependencies=no +-After=sysinit.target local-fs.target systemd-modules-load.service +-Before=multi-user.target ++After=suspend.target hibernate.target hybrid-sleep.target suspend-then-hibernate.target + + [Service] +-Type=oneshot + ExecStart=/usr/bin/amd-disable-c6 --disable_c6_retry ++Type=oneshot + + [Install] +-WantedBy=multi-user.target ++WantedBy=multi-user.target suspend.target hibernate.target hybrid-sleep.target suspend-then-hibernate.target @@ -10,7 +10,7 @@ pkgdesc="Automatically disable the C6 power saving state on AMD Zen (Ryzen / Epy # shellcheck disable=SC2034 pkgver=r13.4eb03b5 # shellcheck disable=SC2034 -pkgrel=1 +pkgrel=2 # shellcheck disable=SC2034 arch=('i686' 'x86_64') # shellcheck disable=SC2034 @@ -32,11 +32,12 @@ url="https://github.com/joakimkistowski/amd-disable-c6.git" # pulled from git so skip the verification check ## # shellcheck disable=SC2034 -source=("${_gitname}::git+${url}#branch=master" "00-fix-sbin.patch" "01-fix-sbin.patch") +source=("${_gitname}::git+${url}#branch=master" "00-fix-sbin.patch" "01-fix-sbin.patch" "02-fix-service.patch") # shellcheck disable=SC2034 sha256sums=('SKIP' 'c1bb428d02994f872e4be2f282ffd5c453f4ebc714a79fc8337032d9d02c1a4a' - '7dfa4a9b54df1cddfc2351d58768e848c07cac6eb8021fa6bd4eb812b9bfcd28') + '7dfa4a9b54df1cddfc2351d58768e848c07cac6eb8021fa6bd4eb812b9bfcd28' + '6f7772c801c57d083c2058f3899422531892ef4e89321f8f7455924418a1e5e6') pkgver() { # shellcheck disable=SC2154 @@ -58,6 +59,7 @@ prepare() { # Apply patches patch -p1 -i "${srcdir}/00-fix-sbin.patch" patch -p1 -i "${srcdir}/01-fix-sbin.patch" + patch -p1 -i "${srcdir}/02-fix-service.patch" } package() { |