summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2020-04-21 14:09:27 +0200
committerRichard Neumann2020-04-21 14:09:27 +0200
commit3c8ce212a08657a5a334a6c36eb2378ce459085a (patch)
tree59261f08631e2b3ef1ba97b512ac841883b79449
parentb668ac757f2c6e48ea2d6d444d7cb09292a4e3bb (diff)
downloadaur-3c8ce212a08657a5a334a6c36eb2378ce459085a.tar.gz
Updated file permissions and cleaned up PKGBUILD.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 466e523b6c19..a8512cc0b2b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = amd-sfh-hid-dkms
pkgdesc = Experimental HID driver modules for the AMD Sensor Fusion Hub (DKMS)
pkgver = 2.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/conqp/linux.git
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c59f8aa14502..435a2e40e685 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,7 @@
_pkgbase=amd-sfh-hid
pkgname="${_pkgbase}-dkms"
pkgver=2.1.3
-pkgrel=1
-_patchfile="${_pkgbase}-${pkgver}-${pkgrel}.patch"
+pkgrel=2
pkgdesc="Experimental HID driver modules for the AMD Sensor Fusion Hub (DKMS)"
arch=('i686' 'x86_64')
url="https://github.com/conqp/linux.git"
@@ -22,11 +21,11 @@ package() {
install -dm 755 "${DEST}"
for file in linux-sfh/drivers/hid/amd-sfh-hid/*; do
- install -m 640 "${file}" "${DEST}"
+ install -m 644 "${file}" "${DEST}"
done
# Copy dkms.conf
- install -m644 dkms.conf "${DEST}"
+ install -m 644 dkms.conf "${DEST}"
# Set name and version
sed -e "s/@PKGVER@/${pkgver}/" -i "${DEST}/dkms.conf"