summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2020-04-20 12:47:33 +0200
committerRichard Neumann2020-04-20 12:47:33 +0200
commit6b9303e86407990aa0b32e3139619f2473a889ac (patch)
treed9dc0056d44b9cadd11d173181e1a7ad110be580
parentc96e7c97a6aa1ab4284e1e5a24786e0baf5ff4ec (diff)
downloadaur-6b9303e86407990aa0b32e3139619f2473a889ac.tar.gz
Fix.
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
3 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3e7eea3e6d7..cafa03f0a88d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = amd-sfh-hid-dkms
pkgdesc = Experimental HID driver modules for the AMD Sensor Fusion Hub (DKMS)
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/conqp/linux.git
arch = i686
arch = x86_64
license = GPL2
makedepends = git
depends = dkms
- source = linux-sfh::https://github.com/conqp/linux.git#branch=amd-sfh#tag=amd-sfh-hid-2.1.0
+ source = linux-sfh::git+https://github.com/conqp/linux.git#tag=amd-sfh-hid-2.1.0
source = dkms.conf
sha256sums = SKIP
- sha256sums = aac46663193f08c6331b76faa8752b08b3169fe586da337f662c0e43428d94fb
- sha256sums = 345bebda48d6dda26f8f0c8282f7c276f946fb14d089b831817eb01fd6ea5dce
+ sha256sums = 18630528fbfc741113082bd6cf11da6d7ce430314b4cd3d56e0e7a3b26866505
pkgname = amd-sfh-hid-dkms
diff --git a/.gitignore b/.gitignore
index f447c5c69e6e..90a9332d3da7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
src/
pkg/
*.pkg.*
-*.patch
+linux-sfh/
diff --git a/PKGBUILD b/PKGBUILD
index cb16bfe8c3d9..52dfb2df6756 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=amd-sfh-hid
pkgname="${_pkgbase}-dkms"
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
_patchfile="${_pkgbase}-${pkgver}-${pkgrel}.patch"
pkgdesc="Experimental HID driver modules for the AMD Sensor Fusion Hub (DKMS)"
arch=('i686' 'x86_64')
@@ -11,18 +11,17 @@ url="https://github.com/conqp/linux.git"
license=('GPL2')
depends=('dkms')
makedepends=('git')
-source=("linux-sfh::${url}#branch=amd-sfh#tag=${_pkgbase}-${pkgver}"
+source=("linux-sfh::git+${url}#tag=${_pkgbase}-${pkgver}"
'dkms.conf')
sha256sums=('SKIP'
- 'aac46663193f08c6331b76faa8752b08b3169fe586da337f662c0e43428d94fb'
- '345bebda48d6dda26f8f0c8282f7c276f946fb14d089b831817eb01fd6ea5dce')
+ '18630528fbfc741113082bd6cf11da6d7ce430314b4cd3d56e0e7a3b26866505')
package() {
local DEST="${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
install -dm 755 "${DEST}"
- for file in drivers/hid/amd-sfh-hid/*; do
+ for file in linux-sfh/drivers/hid/amd-sfh-hid/*; do
install -m 640 "${file}" "${DEST}"
done