summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2020-04-20 12:07:47 +0200
committerRichard Neumann2020-04-20 12:10:52 +0200
commitc96e7c97a6aa1ab4284e1e5a24786e0baf5ff4ec (patch)
tree5b668d972571d433a08333c629e91208ce3e1b06
parent6ff1cc36cc84938f9a0e5324a65c7a1fce49b8fb (diff)
downloadaur-c96e7c97a6aa1ab4284e1e5a24786e0baf5ff4ec.tar.gz
Migrated to git repo as source.
-rw-r--r--.SRCINFO11
-rw-r--r--Makefile.append7
-rw-r--r--PKGBUILD23
-rw-r--r--dkms.conf4
4 files changed, 12 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04829020dbe9..d3e7eea3e6d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = amd-sfh-hid-dkms
pkgdesc = Experimental HID driver modules for the AMD Sensor Fusion Hub (DKMS)
- pkgver = 2
+ pkgver = 2.1.0
pkgrel = 1
- url = https://gist.github.com/conqp/33baa079d9524914c4c0c196200e4f89
+ url = https://github.com/conqp/linux.git
arch = i686
arch = x86_64
license = GPL2
- makedepends = patchutils
+ makedepends = git
depends = dkms
- source = amd-sfh-hid-2-1.patch::https://gist.githubusercontent.com/conqp/33baa079d9524914c4c0c196200e4f89/raw/3d9538ecc877fdad55b6d07ba765ad61c9fc4b9d/amd-sfh.patch
- source = Makefile.append
+ source = linux-sfh::https://github.com/conqp/linux.git#branch=amd-sfh#tag=amd-sfh-hid-2.1.0
source = dkms.conf
- sha256sums = a699d26d398042c8d7a24aa928bc6e66755c7c2a4443ff7a4ce86d1d48dda7e4
+ sha256sums = SKIP
sha256sums = aac46663193f08c6331b76faa8752b08b3169fe586da337f662c0e43428d94fb
sha256sums = 345bebda48d6dda26f8f0c8282f7c276f946fb14d089b831817eb01fd6ea5dce
diff --git a/Makefile.append b/Makefile.append
deleted file mode 100644
index 393cea072890..000000000000
--- a/Makefile.append
+++ /dev/null
@@ -1,7 +0,0 @@
-
-modules:
- $(MAKE) -C /lib/modules/$(KVERSION)/build M=$(PWD) modules
-
-clean:
- $(MAKE) -C /lib/modules/$(KVERSION)/build M=$(PWD) clean
-
diff --git a/PKGBUILD b/PKGBUILD
index 14412dc2d8e9..cb16bfe8c3d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,21 @@
_pkgbase=amd-sfh-hid
pkgname="${_pkgbase}-dkms"
-pkgver=2
+pkgver=2.1.0
pkgrel=1
_patchfile="${_pkgbase}-${pkgver}-${pkgrel}.patch"
pkgdesc="Experimental HID driver modules for the AMD Sensor Fusion Hub (DKMS)"
arch=('i686' 'x86_64')
-url="https://gist.github.com/conqp/33baa079d9524914c4c0c196200e4f89"
+url="https://github.com/conqp/linux.git"
license=('GPL2')
depends=('dkms')
-makedepends=('patchutils')
-source=("${_patchfile}::https://gist.githubusercontent.com/conqp/33baa079d9524914c4c0c196200e4f89/raw/3d9538ecc877fdad55b6d07ba765ad61c9fc4b9d/amd-sfh.patch"
- 'Makefile.append'
+makedepends=('git')
+source=("linux-sfh::${url}#branch=amd-sfh#tag=${_pkgbase}-${pkgver}"
'dkms.conf')
-sha256sums=('a699d26d398042c8d7a24aa928bc6e66755c7c2a4443ff7a4ce86d1d48dda7e4'
+sha256sums=('SKIP'
'aac46663193f08c6331b76faa8752b08b3169fe586da337f662c0e43428d94fb'
'345bebda48d6dda26f8f0c8282f7c276f946fb14d089b831817eb01fd6ea5dce')
-prepare() {
- # Fix patch for DKMS.
- filterdiff -p1 -x "Documentation/*" \
- -x "MAINTAINERS" \
- -x "drivers/hid/Kconfig" \
- -x "drivers/hid/Makefile" \
- "${srcdir}/${_patchfile}" | patch -Np1
-
- # Append DKMS targets to Makefile.
- cat Makefile.append >> drivers/hid/amd-sfh-hid/Makefile
-}
-
package() {
local DEST="${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
diff --git a/dkms.conf b/dkms.conf
index f88ad3b9f040..096470a0e8e5 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -1,7 +1,7 @@
PACKAGE_NAME="amd-sfh-hid"
PACKAGE_VERSION="@PKGVER@"
-MAKE[0]="make modules KVERSION=$kernelver CONFIG_AMD_SFH_HID=m"
-CLEAN="make clean"
+MAKE[0]="make dkms KVERSION=$kernelver CONFIG_AMD_SFH_HID=m"
+CLEAN="make dkms-clean KVERSION=$kernelver CONFIG_AMD_SFH_HID=m"
BUILT_MODULE_NAME[0]="amd-sfh-pci"
BUILT_MODULE_NAME[1]="amd-sfh-hid"
DEST_MODULE_LOCATION[0]="/kernel/drivers/misc"