summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2020-04-22 23:15:16 +0200
committerRichard Neumann2020-04-22 23:15:16 +0200
commitf20712c56feaecaa8c670fcf7710bfd421fb9eea (patch)
treef6f71c172b2a8e9e8d7ab0ce1ccd67d72401df53
parent081e227b548fb3220cccc2ee37fbf37ff9492264 (diff)
downloadaur-f20712c56feaecaa8c670fcf7710bfd421fb9eea.tar.gz
Refactored PKGBUILD.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3a66b9ac7d1..929bd1e0d72d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = amd-sfh-hid-dkms
pkgdesc = Experimental HID driver modules for the AMD Sensor Fusion Hub (DKMS)
pkgver = 2.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/conqp/linux.git
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 25bcb2fd2b44..8137e8d29451 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=amd-sfh-hid
pkgname="${_pkgbase}-dkms"
pkgver=2.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="Experimental HID driver modules for the AMD Sensor Fusion Hub (DKMS)"
arch=('i686' 'x86_64')
url="https://github.com/conqp/linux.git"
@@ -17,10 +17,11 @@ sha256sums=('SKIP'
package() {
local DEST="${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
+ local SRC="linux-sfh/drivers/hid/amd-sfh-hid"
install -dm 755 "${DEST}"
- for file in linux-sfh/drivers/hid/amd-sfh-hid/*; do
+ for file in "${SRC}"/*.[hc] "${SRC}/Makefile"; do
install -m 644 "${file}" "${DEST}"
done