summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-04-30 17:28:35 +0700
committerKonstantin Shalygin2018-04-30 17:28:47 +0700
commit88d0ff4203a18bb9bbe8d06e445dc583b78908db (patch)
treebe1408259715c695d7bf51430c46a6fe49fea5e9
downloadaur-88d0ff4203a18bb9bbe8d06e445dc583b78908db.tar.gz
Initial support amdcovc
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6da64ff57afb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Apr 30 10:28:07 UTC 2018
+pkgbase = amdcovc
+ pkgdesc = Control AMD Overdrive settings with or without X.
+ pkgver = 0.3.9.2
+ pkgrel = 1
+ url = https://github.com/matszpk/amdcovc
+ arch = x86_64
+ license = GPL
+ depends = ocl-icd
+ depends = pciutils
+ source = https://github.com/matszpk/amdcovc/archive/0.3.9.2.tar.gz
+ sha256sums = a3b4e21f342b4529301f80c3b22880576e3b85d22f4dd98be4c56b3618c49077
+
+pkgname = amdcovc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7c6927b4669a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/*
+src/*
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..840efe8a5eca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Konstantin Shalygin <k0ste@k0ste.ru>
+# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
+
+pkgname='amdcovc'
+pkgver='0.3.9.2'
+pkgrel='1'
+pkgdesc='Control AMD Overdrive settings with or without X.'
+arch=('x86_64')
+url="https://github.com/matszpk/${pkgname}"
+depends=('ocl-icd' 'pciutils')
+license=('GPL')
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('a3b4e21f342b4529301f80c3b22880576e3b85d22f4dd98be4c56b3618c49077')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm775 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}