summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax2018-12-03 17:06:20 +1100
committerMax2018-12-03 17:06:20 +1100
commit2e079c3228b0422e2de95fa6713c17a8ce17c7fa (patch)
tree06250eebba26ed583731bb3be3ec1fddd56ff932
downloadaur-2e079c3228b0422e2de95fa6713c17a8ce17c7fa.tar.gz
initial package upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab411c58cac5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = amdgpu-fan
+ pkgdesc = Python daemon for controlling the fans on amdgpu cards
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/chestm007/amdgpu-fan
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ depends = python
+ depends = python-yaml
+ depends = python-matplotlib
+ depends = python-numpy
+ depends = python-scipy
+ source = git+https://github.com/chestm007/amdgpu-fan/
+ md5sums = SKIP
+
+pkgname = amdgpu-fan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3e188570c12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Max Chesterfield <`echo Y2hlc3RtMDA3QGhvdG1haWwuY29tCg== | base64 -d`>
+
+
+pkgname=amdgpu-fan
+pkgdesc="Python daemon for controlling the fans on amdgpu cards"
+pkgver=0.0.1.r0.g0eeaa8e
+pkgrel=1
+arch=('any')
+license=('GPL2')
+depends=('python' 'python-yaml' 'python-matplotlib' 'python-numpy' 'python-scipy')
+makedepends=('python-setuptools')
+url="https://github.com/chestm007/amdgpu-fan"
+source=("git+https://github.com/chestm007/amdgpu-fan/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/amdgpu-fan"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/amdgpu-fan"
+ sed -i "s/PROJECTVERSION/$pkgver/g" setup.py
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/amdgpu-fan"
+ sed -i "s/PROJECTVERSION/$pkgver/g" setup.py
+ python setup.py install --prefix=/usr --root="$pkgdir"
+ mkdir -p "$pkgdir/usr/lib/systemd/system"
+ cp amdgpu-fan.service "$pkgdir/usr/lib/systemd/system/"
+}