summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Cheng2021-04-01 21:07:32 -0400
committerEric Cheng2021-04-01 21:07:32 -0400
commit66a64a568b7241ee9fe04e272fb170cbfbadecf3 (patch)
tree8ae00ea10703d03ada4f8c2447a5e36789ba0828
parentce387dab59422438488196e64303826251312069 (diff)
downloadaur-66a64a568b7241ee9fe04e272fb170cbfbadecf3.tar.gz
Updating to 0.1.0, new fork
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--amdgpu-fan.service9
-rw-r--r--setup.py29
4 files changed, 50 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56d1b9f4b8f9..a89cefe2e2c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = amdgpu-fan
- pkgdesc = Python daemon for controlling the fans on amdgpu cards
- pkgver = 0.0.6
+ pkgdesc = Python daemon for controlling the fans on AMDGPU cards
+ pkgver = 0.1.0
pkgrel = 1
- url = https://github.com/chestm007/amdgpu-fan
+ url = https://github.com/zzkW35/amdgpu-fan
arch = any
license = GPL2
makedepends = python-setuptools
depends = python
depends = python-yaml
depends = python-numpy
- source = https://github.com/chestm007/amdgpu-fan/archive/0.0.6.tar.gz
+ source = https://github.com/zzkW35/amdgpu-fan/archive/0.1.0.tar.gz
md5sums = SKIP
pkgname = amdgpu-fan
diff --git a/PKGBUILD b/PKGBUILD
index 070005f807da..6f7e8e1be3cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Max Chesterfield <`echo Y2hlc3RtMDA3QGhvdG1haWwuY29tCg== | base64 -d`>
-
+# Maintainer: Eric Cheng <ericcheng@hey.com>
+# Maintainer: Filippo Roggi <zzkw35@gmail.com>
+# Contributor: Max Chesterfield <`echo Y2hlc3RtMDA3QGhvdG1haWwuY29tCg== | base64 -d`>
pkgname=amdgpu-fan
-pkgdesc="Python daemon for controlling the fans on amdgpu cards"
-pkgver=0.0.6
+pkgdesc="Python daemon for controlling the fans on AMDGPU cards"
+pkgver=0.1.0
pkgrel=1
arch=('any')
license=('GPL2')
depends=('python' 'python-yaml' 'python-numpy')
makedepends=('python-setuptools')
-url="https://github.com/chestm007/amdgpu-fan"
-source=("https://github.com/chestm007/amdgpu-fan/archive/${pkgver}.tar.gz")
+url="https://github.com/zzkW35/amdgpu-fan"
+source=("https://github.com/zzkW35/amdgpu-fan/archive/${pkgver}.tar.gz")
md5sums=('SKIP')
build() {
@@ -25,4 +26,4 @@ package() {
python setup.py install --prefix=/usr --root="$pkgdir"
mkdir -p "$pkgdir/usr/lib/systemd/system"
install -Dm644 amdgpu-fan.service "$pkgdir/usr/lib/systemd/system/"
-}
+} \ No newline at end of file
diff --git a/amdgpu-fan.service b/amdgpu-fan.service
new file mode 100644
index 000000000000..35469b293eea
--- /dev/null
+++ b/amdgpu-fan.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=AMDGPU fan controller
+
+[Service]
+ExecStart=/usr/bin/amdgpu-fan
+Restart=always
+
+[Install]
+WantedBy=sysinit.target
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..9ae478cbea6a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+from distutils.core import setup
+
+from setuptools import find_packages
+
+with open('README.md') as f:
+ readme = f.read()
+
+
+setup(
+ name='amdgpu_fan',
+ version='PROJECTVERSION',
+ packages=find_packages(),
+ url='https://github.com/chestm007/amdgpu-fan',
+ license='GPL-2.0',
+ author='Max Chesterfield',
+ author_email='chestm007@hotmail.com',
+ maintainer='Filippo Roggi',
+ maintainer_email='zzkw35@gmail.com',
+ description='amdgpu fan controller',
+ long_description=readme,
+ install_requires=[
+ 'pyyaml',
+ 'numpy',
+ ],
+ entry_points="""
+ [console_scripts]
+ amdgpu-fan=amdgpu_fan.controller:main
+ """,
+)