summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarjan Krijan2019-07-13 19:19:30 +0200
committerDarjan Krijan2019-07-13 19:19:30 +0200
commit2e3162797cecfd874a246181c94f2f07b07084ae (patch)
treee3972a763de03af1ca49752f1d09f14957beaa4f
downloadaur-2e3162797cecfd874a246181c94f2f07b07084ae.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8a56002a4b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = amduprof
+ pkgdesc = AMD uProf is a performance analysis tool for applications running on Windows and Linux operating systems. It allows developers to better understand the runtime performance of their application and to identify ways to improve its performance.
+ pkgver = 3.0.281
+ pkgrel = 1
+ url = https://developer.amd.com/amd-uprof/
+ arch = x86_64
+ license = custom
+ options = staticlibs
+ options = !strip
+ options = libtool
+ source = file://AMDuProf_Linux_x64_3.0.281.tar.bz2
+ sha256sums = 9a5d3800ebd0c184ab5faed463bd31567eb72d475973c0698946db2e0e817e2b
+
+pkgname = amduprof
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..336c546a01f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Darjan Krijan (daren) <darjan_krijan@gmx.de>
+# Manual download of 'AMDuProf_Linux_x64_${pkgver}.tar.bz2' required from upstream
+
+pkgname=amduprof
+pkgver=3.0.281
+pkgrel=1
+pkgdesc="AMD uProf is a performance analysis tool for applications running on Windows and Linux operating systems. It allows developers to better understand the runtime performance of their application and to identify ways to improve its performance."
+arch=('x86_64')
+license=('custom')
+url="https://developer.amd.com/amd-uprof/"
+source=("file://AMDuProf_Linux_x64_${pkgver}.tar.bz2")
+options=('staticlibs' '!strip' 'libtool')
+sha256sums=("9a5d3800ebd0c184ab5faed463bd31567eb72d475973c0698946db2e0e817e2b")
+
+package() {
+ mkdir -p ${pkgdir}/opt/amduprof
+ cp -r ${srcdir}/AMDuProf_Linux_x64_${pkgver}/* ${pkgdir}/opt/amduprof
+
+ mkdir -p ${pkgdir}/usr/bin
+ ln -s /opt/amduprof/bin/AMDuProf ${pkgdir}/usr/bin/amduprof
+ ln -s /opt/amduprof/bin/AMDuProfCLI ${pkgdir}/usr/bin/amduprof-cli
+}