summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarijn Suijten2023-05-25 22:44:47 +0200
committerMarijn Suijten2023-05-25 22:50:11 +0200
commit574fb07fb58c5fdb1d6e2079fe29f8f0ee688f69 (patch)
tree6a3ee27cb4d1bfa60cb2b59a66c9f7c4a294c358
parent190a1f8dcfa64a25d42d28053245abb1b9b96f3f (diff)
downloadaur-574fb07fb58c5fdb1d6e2079fe29f8f0ee688f69.tar.gz
Embed PAL patch as file instead of downloading from varying source
-rw-r--r--.SRCINFO6
-rw-r--r--0001-rdf-Include-cstdint-header-explicitly-for-std-int64_.patch40
-rw-r--r--PKGBUILD8
3 files changed, 47 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 103db33fa3e9..19b3d996efd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = amdvlk-git
pkgdesc = AMD's standalone Vulkan driver
- pkgver = 2023.Q2.2.r0.ec40bda
+ pkgver = 2023.Q2.2.r0.ff6b9ba
pkgrel = 1
url = https://github.com/GPUOpen-Drivers
arch = x86_64
@@ -23,7 +23,7 @@ pkgbase = amdvlk-git
provides = vulkan-driver
conflicts = vulkan-amdvlk
conflicts = amdvlk
- source = https://patch-diff.githubusercontent.com/raw/GPUOpen-Drivers/pal/pull/94.patch
- sha256sums = df333990b3ebd39f7b5e5d36ca74e0c1814329c64ca942fb03ae037e75e8c5bb
+ source = 0001-rdf-Include-cstdint-header-explicitly-for-std-int64_.patch
+ sha256sums = 0943859eeab66bf24598cfba99e07d839bb018360e93ffb8b5c94b45ab36d389
pkgname = amdvlk-git
diff --git a/0001-rdf-Include-cstdint-header-explicitly-for-std-int64_.patch b/0001-rdf-Include-cstdint-header-explicitly-for-std-int64_.patch
new file mode 100644
index 000000000000..c36dc6db25a6
--- /dev/null
+++ b/0001-rdf-Include-cstdint-header-explicitly-for-std-int64_.patch
@@ -0,0 +1,40 @@
+From 56868b78dddddd975f2c1dfe671646f7b434d29b Mon Sep 17 00:00:00 2001
+From: Marijn Suijten <marijns95@gmail.com>
+Date: Tue, 23 May 2023 10:23:10 +0200
+Subject: [PATCH] rdf: Include `cstdint` header explicitly for `std::int64_t`
+ and friends
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+On gcc-13 these integer types appear to no longer be included via
+`(c)string` or other `std` headers (according to a [similar fix]),
+resulting in many of the following compiler errors in `amdrdf.{cpp,h}`:
+
+ In file included from pal/src/core/imported/rdf/rdf/src/amdrdf.cpp:25:
+ pal/src/core/imported/rdf/rdf/inc/amdrdf.h:112:39: error: ‘int64_t’ in namespace ‘std’ does not name a type
+ 112 | int (*Read)(void* ctx, const std::int64_t count, void* buffer, std::int64_t* bytesRead);
+ | ^~~~~~~
+
+Solve this by including `cstdint` explicitly.
+
+[similar fix]: https://github.com/google/breakpad/commit/7ea7ded187b4d739239f3ab7082fcd5a2ccc1eaa
+---
+ src/core/imported/rdf/rdf/inc/amdrdf.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/core/imported/rdf/rdf/inc/amdrdf.h b/src/core/imported/rdf/rdf/inc/amdrdf.h
+index 2ac8b1ce..cbee874d 100644
+--- a/src/core/imported/rdf/rdf/inc/amdrdf.h
++++ b/src/core/imported/rdf/rdf/inc/amdrdf.h
+@@ -25,6 +25,7 @@
+ #pragma once
+
+ #include <cstddef>
++#include <cstdint>
+ #include <cstring>
+ #include <functional>
+ #include <memory>
+--
+2.40.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 08bf7c741ee5..0e5e261d8228 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Adrià Cereto i Massagué <ssorgatem at gmail.com>
pkgname=amdvlk-git
-pkgver=2023.Q2.2.r0.ec40bda
+pkgver=2023.Q2.2.r0.ff6b9ba
pkgrel=1
pkgdesc="AMD's standalone Vulkan driver"
arch=(x86_64)
@@ -14,8 +14,8 @@ depends=('vulkan-icd-loader')
provides=('vulkan-amdvlk' 'amdvlk' 'vulkan-driver')
conflicts=('vulkan-amdvlk' 'amdvlk')
makedepends=('xorgproto' 'xorg-server-devel' 'libxrandr' 'cmake' 'python' 'libxml2' 'wayland' 'libdrm' 'git' 'ninja' 'repo' 'directx-shader-compiler')
-source=('https://patch-diff.githubusercontent.com/raw/GPUOpen-Drivers/pal/pull/94.patch')
-sha256sums=('df333990b3ebd39f7b5e5d36ca74e0c1814329c64ca942fb03ae037e75e8c5bb')
+source=('0001-rdf-Include-cstdint-header-explicitly-for-std-int64_.patch')
+sha256sums=('0943859eeab66bf24598cfba99e07d839bb018360e93ffb8b5c94b45ab36d389')
pkgver() {
pushd .repo/manifests/ > /dev/null
@@ -34,7 +34,7 @@ prepare() {
done
msg 'Applying https://github.com/GPUOpen-Drivers/pal/pull/94'
- patch -p1 -d drivers/pal < "$srcdir/94.patch"
+ git -C drivers/pal am "$srcdir/0001-rdf-Include-cstdint-header-explicitly-for-std-int64_.patch"
}
build() {