summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Carlier2017-12-23 18:57:36 +0100
committerLaurent Carlier2017-12-23 18:57:36 +0100
commit6b97446e9bb83f4132d6b80bd8c7e312ded26b4c (patch)
tree227ec5c93d080dc3f40647e8456eec62bd7b8950
parent8ffeba1b4569d87bda575de0ee35429a9c4bcf5f (diff)
downloadaur-6b97446e9bb83f4132d6b80bd8c7e312ded26b4c.tar.gz
- Complete Makedepends (fix building in chroot)
- Use patch instead of git am (fix building in chroot) - Change name of llvm tree (avoid conflicts if srcdest is defined) - Add missing license file (namcap warning) - Various cleanup
-rw-r--r--PKGBUILD54
-rw-r--r--amd_icd64.json8
2 files changed, 32 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7662cf215d43..6324e4b04d95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,62 +9,56 @@ arch=(x86_64)
url="https://github.com/GPUOpen-Drivers"
license=('MIT')
depends=('vulkan-icd-loader')
-provides=(vulkan-amdvlk)
-#conflicts=()
-#TODO: makedepends=('libdrm' 'dri2proto' 'glproto' 'libxxf86vm' 'libxdamage' 'expat>=2.0.1' 'libxmu'
-# 'talloc' 'wayland' 'pkgconfig' 'imake' 'xorg-server-devel' 'python2-mako' 'python' 'git')
-makedepends=('dri2proto')
-
-source=('git+https://github.com/GPUOpen-Drivers/llvm.git#branch=amd-vulkan-master'
+provides=('vulkan-amdvlk')
+conflicts=('vulkan-amdvlk')
+makedepends=('dri2proto' 'xorg-server-devel' 'cmake' 'python' 'git')
+source=('llvm-amdvlk::git+https://github.com/GPUOpen-Drivers/llvm.git#branch=amd-vulkan-master'
'git+https://github.com/GPUOpen-Drivers/xgl.git#branch=dev'
'git+https://github.com/GPUOpen-Drivers/pal.git#branch=dev'
'git+https://github.com/GPUOpen-Drivers/AMDVLK.git#branch=dev'
'0001-fix-compile-error-on-clang.patch' # TODO: maybe not necessary on gcc
'0001-remove-linking-with-whole-archive.patch'
- 'amdPalSettings.cfg')
+ 'amdPalSettings.cfg'
+ 'amd_icd64.json')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'9d2399c3cfd424c5c0645892306f1794de61a8270f95683ea1785a78e0326c5c'
'4669fda7c492ae6f655e9ad3bb2c4782753b49350a29af29883d43c02d627f46'
- '5f798911bf1cbbe5a83f5ae4886107ef0d02be5753450753ae2d3fc6f80e7012')
+ '5f798911bf1cbbe5a83f5ae4886107ef0d02be5753450753ae2d3fc6f80e7012'
+ '39c26b6d91a8c5b42818a6cc3529b3803aba8f3a759d8eb6b682ecb027f4762c')
+
pkgver() {
- XGL_VER=$(cd xgl; printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
- #PAL_VER=$(cd pal; printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
- echo "$XGL_VER"
+ XGL_VER=$(cd xgl; printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
+ #PAL_VER=$(cd pal; printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
+ echo "$XGL_VER"
}
prepare() {
cd xgl
- git am -3 ../0001-fix-compile-error-on-clang.patch
- git am -3 ../0001-remove-linking-with-whole-archive.patch
+ patch -Np1 -i ${srcdir}/0001-fix-compile-error-on-clang.patch
+ patch -Np1 -i ${srcdir}/0001-remove-linking-with-whole-archive.patch
}
build() {
- echo "building xgl..."
+ msg "building xgl..."
cd xgl
- cmake -H. -Bbuilds/Release64 -DCMAKE_BUILD_TYPE=Release -DCMAKE_MODULE_PATH=$PWD/../pal/cmake/Modules -DXGL_PAL_PATH:PATH=$PWD/../pal -DCMAKE_C_FLAGS="-DLINUX -D__x86_64__ -D__AMD64__" -DCMAKE_CXX_FLAGS="-DLINUX -D__x86_64__ -D__AMD64__" -DXGL_LLVM_SRC_PATH=$PWD/../llvm
+ cmake -H. -Bbuilds/Release64 -DCMAKE_BUILD_TYPE=Release -DCMAKE_MODULE_PATH=$PWD/../pal/cmake/Modules -DXGL_PAL_PATH:PATH=$PWD/../pal \
+ -DCMAKE_C_FLAGS="-DLINUX -D__x86_64__ -D__AMD64__" -DCMAKE_CXX_FLAGS="-DLINUX -D__x86_64__ -D__AMD64__" -DXGL_LLVM_SRC_PATH=$PWD/../llvm-amdvlk
cd builds/Release64
make
- echo "bulding xgl finished!"
+ msg "bulding xgl finished!"
}
package() {
- install -m755 -d "${pkgdir}"/etc/vulkan/icd.d
- install -m755 -d "${pkgdir}"/etc/amd
install -m755 -d "${pkgdir}"/usr/lib
+ install -m755 -d "${pkgdir}"/usr/share/vulkan/icd.d
+ install -m755 -d "${pkgdir}"/usr/share/licenses/amdvlk-git
+ install -m755 -d "${pkgdir}"/etc/amd
install xgl/builds/Release64/icd/amdvlk64.so "${pkgdir}"/usr/lib/
-
-echo '{
- "file_format_version": "1.0.0",
- "ICD": {
- "library_path": "/usr/lib64/amdvlk64.so",
- "abi_versions": "0.9.0"
- }
-}
-' >> "${pkgdir}"/etc/vulkan/icd.d/amd_icd64.json
-
- install amdPalSettings.cfg "${pkgdir}"/etc/amd
+ install amd_icd64.json "${pkgdir}"/usr/share/vulkan/icd.d/
+ install AMDVLK/LICENSE.txt "${pkgdir}"/usr/share/licenses/amdvlk-git/
+ install amdPalSettings.cfg "${pkgdir}"/etc/amd/
}
diff --git a/amd_icd64.json b/amd_icd64.json
new file mode 100644
index 000000000000..4af6b89a6920
--- /dev/null
+++ b/amd_icd64.json
@@ -0,0 +1,8 @@
+{
+ "file_format_version": "1.0.0",
+ "ICD": {
+ "library_path": "/usr/lib/amdvlk64.so",
+ "abi_versions": "0.9.0"
+ }
+}
+