summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Coffin2020-01-19 17:00:40 -0700
committerMatt Coffin2020-01-19 17:26:20 -0700
commit7ffc2ddc104c3b55a67673080ac078488c1ba115 (patch)
tree3a8439427adb339eb59261b196e58055f4d0dee5
parent02ba4fb98a6ea249d3b0d96918a1036b43cc01c4 (diff)
downloadaur-7ffc2ddc104c3b55a67673080ac078488c1ba115.tar.gz
Fix build for xorg cleanup fallout
The xorg cleanup (https://www.archlinux.org/news/xorg-cleanup-requires-manual-intervention/) caused the build to break due to the dependency dri2proto being rolled into xorgproto
-rw-r--r--.SRCINFO24
-rw-r--r--0001-build-Fix-clang-linking.patch25
-rw-r--r--0001-build-Remove-forced-Werror-option.patch40
-rw-r--r--PKGBUILD21
4 files changed, 90 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d210965907a8..9359aa46d960 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
-# Generated by mksrcinfo v8
-# Mon Mar 25 10:19:15 UTC 2019
pkgbase = amdvlk-git
pkgdesc = AMD's standalone Vulkan driver
- pkgver = r43.6d9d93a
+ pkgver = v.2019.Q4.5.r0.e6d1928
pkgrel = 1
url = https://github.com/GPUOpen-Drivers
arch = x86_64
license = MIT
- makedepends = dri2proto
+ makedepends = xorgproto
makedepends = xorg-server-devel
makedepends = libxrandr
makedepends = cmake
@@ -16,22 +14,18 @@ pkgbase = amdvlk-git
makedepends = wayland
makedepends = libdrm
makedepends = git
+ makedepends = ninja
+ makedepends = repo
depends = vulkan-icd-loader
provides = vulkan-amdvlk
provides = vulkan-driver
conflicts = vulkan-amdvlk
- source = llvm::git+https://github.com/GPUOpen-Drivers/llvm.git#branch=amd-vulkan-dev
- source = git+https://github.com/GPUOpen-Drivers/xgl.git#branch=dev
- source = git+https://github.com/GPUOpen-Drivers/pal.git#branch=dev
source = git+https://github.com/GPUOpen-Drivers/wsa.git#branch=master
- source = git+https://github.com/GPUOpen-Drivers/AMDVLK.git#branch=dev
- source = git+https://github.com/GPUOpen-Drivers/llpc.git#branch=dev
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = 0001-build-Remove-forced-Werror-option.patch
+ source = 0001-build-Fix-clang-linking.patch
+ sha512sums = SKIP
+ sha512sums = ff9dcfe2f3b739b74a51dc82e3469f8b4ad1a0b044d868fbb99e0c07dd5f7bdc1e5bb1ae93f44c25d6dd90a5b7ddbb294fa29e8082f40e5794269143a1af2467
+ sha512sums = 39152c24ca6e6bdbd16d7fb66438117101c106a6e5e4e5bcc1248495e6d2f6a1907a639750b1eb25c3d754f7f21801de2b15b232b1c974748551927b783abceb
pkgname = amdvlk-git
diff --git a/0001-build-Fix-clang-linking.patch b/0001-build-Fix-clang-linking.patch
new file mode 100644
index 000000000000..ab2dfad4b2c5
--- /dev/null
+++ b/0001-build-Fix-clang-linking.patch
@@ -0,0 +1,25 @@
+From b5680fc14a577dd6dd57bd3d8568f0b05871b1c8 Mon Sep 17 00:00:00 2001
+From: Matt Coffin <mcoffin13@gmail.com>
+Date: Sat, 9 Nov 2019 11:01:58 -0700
+Subject: [PATCH] build: Fix clang linking
+
+---
+ icd/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/icd/CMakeLists.txt b/icd/CMakeLists.txt
+index a60a9db..06b21f7 100644
+--- a/icd/CMakeLists.txt
++++ b/icd/CMakeLists.txt
+@@ -381,7 +381,7 @@ if (UNIX)
+
+ target_link_libraries(xgl PRIVATE c stdc++ ${CMAKE_DL_LIBS} pthread)
+
+- if(NOT ICD_USE_GCC)
++ if((NOT ICD_USE_GCC) AND (NOT "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang"))
+ message(WARNING "Intel ICC untested in CMake.")
+ target_link_libraries(xgl PRIVATE -fabi-version=0 -static-intel)
+ endif()
+--
+2.23.0
+
diff --git a/0001-build-Remove-forced-Werror-option.patch b/0001-build-Remove-forced-Werror-option.patch
new file mode 100644
index 000000000000..a666c148e457
--- /dev/null
+++ b/0001-build-Remove-forced-Werror-option.patch
@@ -0,0 +1,40 @@
+From b37631a8216051f4c5916f48570ff4ad3c1091c4 Mon Sep 17 00:00:00 2001
+From: Matt Coffin <mcoffin13@gmail.com>
+Date: Sat, 9 Nov 2019 10:50:55 -0700
+Subject: [PATCH] build: Remove forced -Werror option
+
+---
+ CMakeLists.txt | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fb44edb..5ec3b72 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -83,7 +83,6 @@ if(UNIX)
+ -fvisibility-inlines-hidden
+ -fcolor-diagnostics
+ -Wall
+- -Werror
+ -Wno-invalid-offsetof
+ -Wno-missing-braces
+ )
+@@ -460,7 +459,6 @@ if(UNIX)
+ -fvisibility-inlines-hidden
+ -fcolor-diagnostics
+ -Wall
+- -Werror
+ )
+ target_compile_options(vfx PRIVATE $<$<COMPILE_LANGUAGE:CXX>:
+ -std=c++14
+@@ -542,7 +540,6 @@ if(UNIX)
+ -fvisibility-inlines-hidden
+ -fcolor-diagnostics
+ -Wall
+- -Werror
+ -Wno-missing-braces
+ )
+ target_compile_options(amdllpc PRIVATE $<$<COMPILE_LANGUAGE:CXX>:
+--
+2.23.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 16bbfb29efe6..fba1ce3685e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Maintainer: AdriƠ Cereto i MassaguƩ <ssorgatem at gmail.com>
pkgname=amdvlk-git
-pkgver=v.v.2019.Q3.5.r1.a14d42d
-pkgrel=2
+pkgver=v.2019.Q4.5.r0.e6d1928
+pkgrel=1
pkgdesc="AMD's standalone Vulkan driver"
arch=(x86_64)
url="https://github.com/GPUOpen-Drivers"
@@ -12,9 +12,13 @@ license=('MIT')
depends=('vulkan-icd-loader')
provides=('vulkan-amdvlk' 'vulkan-driver')
conflicts=('vulkan-amdvlk')
-makedepends=('dri2proto' 'xorg-server-devel' 'libxrandr' 'cmake' 'python' 'libxml2' 'wayland' 'libdrm' 'git' 'ninja' 'repo')
-source=('git+https://github.com/GPUOpen-Drivers/wsa.git#branch=master')
-sha512sums=('SKIP')
+makedepends=('xorgproto' 'xorg-server-devel' 'libxrandr' 'cmake' 'python' 'libxml2' 'wayland' 'libdrm' 'git' 'ninja' 'repo')
+source=('git+https://github.com/GPUOpen-Drivers/wsa.git#branch=master'
+ 0001-build-Remove-forced-Werror-option.patch
+ 0001-build-Fix-clang-linking.patch)
+sha512sums=('SKIP'
+ 'ff9dcfe2f3b739b74a51dc82e3469f8b4ad1a0b044d868fbb99e0c07dd5f7bdc1e5bb1ae93f44c25d6dd90a5b7ddbb294fa29e8082f40e5794269143a1af2467'
+ '39152c24ca6e6bdbd16d7fb66438117101c106a6e5e4e5bcc1248495e6d2f6a1907a639750b1eb25c3d754f7f21801de2b15b232b1c974748551927b783abceb')
pkgver() {
pushd drivers/AMDVLK > /dev/null
@@ -50,6 +54,13 @@ prepare() {
sed -i "s/-Werror//g" "$srcdir"/$i
done
+ pushd drivers/llpc
+ patch -p1 < $srcdir/0001-build-Remove-forced-Werror-option.patch
+ popd
+ pushd drivers/xgl
+ patch -p1 < $srcdir/0001-build-Fix-clang-linking.patch
+ popd
+
msg 'No patches to apply...'
}