summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2018-03-16 15:37:52 +0100
committerChristoph Haag2018-03-16 15:37:52 +0100
commitb1934e57e1bafdffba7d9c087d83453794b2ccfd (patch)
tree321daa25f0f428b38506255bb22f9021f26561b7
parente267266ebfa873ebdd71bdae646a2a2a8360ce72 (diff)
downloadaur-b1934e57e1bafdffba7d9c087d83453794b2ccfd.tar.gz
include some changes from lib32-amdvlk-git
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c76b0177e9cc..60f12dfb0c2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,9 @@ arch=(x86_64)
url="https://github.com/GPUOpen-Drivers"
license=('MIT')
depends=('vulkan-icd-loader')
-provides=('vulkan-amdvlk')
+provides=('vulkan-amdvlk' 'vulkan-driver')
conflicts=('vulkan-amdvlk')
-makedepends=('dri2proto' 'xorg-server-devel' 'cmake' 'python' 'git')
+makedepends=('dri2proto' 'xorg-server-devel' 'cmake' 'python' 'libxml2' 'git')
source=('llvm::git+https://github.com/GPUOpen-Drivers/llvm.git#branch=amd-vulkan-dev'
'git+https://github.com/GPUOpen-Drivers/xgl.git#branch=dev'
'git+https://github.com/GPUOpen-Drivers/pal.git#branch=dev'
@@ -39,7 +39,9 @@ prepare() {
build() {
msg "building xgl..."
cd xgl
- cmake -H. -Bbuilds/Release64 -DCMAKE_BUILD_TYPE=Release
+ cmake -H. -Bbuilds/Release64 \
+ -DCMAKE_BUILD_TYPE=Release
+
cd builds/Release64
make
msg "building xgl finished!"