summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshrh2022-08-03 03:51:08 -0400
committereshrh2022-08-03 03:51:08 -0400
commit0d76c3ecd6f89a087f9e29669e7a148a1306a466 (patch)
treed115bdb50141b24efadd691ab5b1878909300c14
parentef2656c6808e65a53ade33044b94542cb3fb4580 (diff)
downloadaur-0d76c3ecd6f89a087f9e29669e7a148a1306a466.tar.gz
remove pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50a015c03e07..ad9560d60ff6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ames
pkgdesc = Update anki cards with desktop audio and images
- pkgver = v0.1.4.r3.gf0e1fca
+ pkgver = v0.1.4
pkgrel = 1
url = https://github.com/eshrh/ames
install = ames.install
@@ -12,7 +12,7 @@ pkgbase = ames
depends = xdotool
depends = libnotify
depends = xsel
- source = git+https://github.com/eshrh/ames
+ source = ames-v0.1.4.tar.gz::https://github.com/eshrh/ames/archive/refs/tags/v0.1.4.tar.gz
md5sums = SKIP
pkgname = ames
diff --git a/PKGBUILD b/PKGBUILD
index e2aad440ad31..c5af5b793c80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,19 @@
# Maintainer: esrh : email at esrh.me/pages/contact.html
pkgname=ames
-pkgver=v0.1.4.r3.gf0e1fca
+pkgver=v0.1.4
pkgrel=1
pkgdesc="Update anki cards with desktop audio and images"
arch=('any')
url="https://github.com/eshrh/ames"
license=('GPL3')
depends=('pulseaudio' 'ffmpeg' 'maim' 'xdotool' 'libnotify' 'xsel')
-source=("git+https://github.com/eshrh/ames")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/eshrh/ames/archive/refs/tags/$pkgver.tar.gz")
md5sums=('SKIP')
install="ames.install"
-
-pkgver() {
- cd "$pkgname"
- git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
package() {
- cd "$srcdir/$pkgname"
- install -Dm755 ames.sh "$pkgdir"/usr/bin/ames
- install -Dm644 config "$pkgdir"/usr/share/ames/config
+ tar -xzf "$pkgname-$pkgver.tar.gz"
+ cd "$srcdir/$pkgname-${pkgver:1}"
+ install -Dm755 ames.sh "$pkgdir"/usr/bin/ames
+ install -Dm644 config "$pkgdir"/usr/share/ames/config
}
-