summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshrh2021-02-09 22:40:18 -0500
committereshrh2021-02-09 22:40:18 -0500
commite37b01d4f713099dde27e1b1c9438c5a7caf0e94 (patch)
tree16d5e37fb45ef3b1f86bed3426a9147b45281e00
downloadaur-e37b01d4f713099dde27e1b1c9438c5a7caf0e94.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--ames.install4
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48bc2ab81cab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ames
+ pkgdesc = Update anki cards with desktop audio and images
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Ajatt-Tools/ames
+ install = ames.install
+ arch = any
+ license = GPL3
+ depends = pulseaudio
+ depends = ffmpeg
+ depends = maim
+ depends = xdotool
+ depends = libnotify
+ source = ames::git+https://github.com/Ajatt-Tools/ames
+ md5sums = SKIP
+
+pkgname = ames
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1545966ac444
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: esrh : email at esrh at netc dot eu
+pkgname=ames
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Update anki cards with desktop audio and images"
+arch=('any')
+url="https://github.com/Ajatt-Tools/ames"
+license=('GPL3')
+depends=('pulseaudio' 'ffmpeg' 'maim' 'xdotool' 'libnotify')
+source=("ames::git+https://github.com/Ajatt-Tools/ames")
+md5sums=('SKIP')
+install="ames.install"
+
+
+pkgver() {
+ cd "$pkgname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 ames.sh "$pkgdir"/usr/bin/ames
+ install -Dm644 config "$pkgdir"/usr/share/ames/config
+}
+
diff --git a/ames.install b/ames.install
new file mode 100644
index 000000000000..fe3cdeed47a0
--- /dev/null
+++ b/ames.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo -e '\033[1mCopy the default config from /usr/share/ames/config to ~/.config/ames/config and edit as necessary\033[0m'
+}
+