summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-22 17:38:59 +0800
committerzxp198210052024-01-22 17:38:59 +0800
commit8c342f7aa2fd58a1c5f1ea41cc0ebebe437421a0 (patch)
tree60fd5ae5f9e2faa50142bafa70c86357d6fe86c7
parentf6169a03694ff646424973cd92f663c2f666b7dd (diff)
downloadaur-8c342f7aa2fd58a1c5f1ea41cc0ebebe437421a0.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--amethyst-player.sh13
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d7266a769ed..6a3bb48d82ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = amethyst-player-bin
pkgdesc = A cross-platform music player made with Typescript
pkgver = 1.9.16
- pkgrel = 1
+ pkgrel = 2
url = https://amethyst.pages.dev/
arch = aarch64
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = amethyst-player-bin
source = LICENSE-1.9.16::https://raw.githubusercontent.com/Geoxor/Amethyst/v1.9.16/LICENSE
source = amethyst-player.sh
sha256sums = 80d12b7c086562e81c66238a2b7c596c335a4da2a047f9880c39ee03b85c28bb
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
source_aarch64 = amethyst-player-1.9.16-aarch64.deb::https://github.com/Geoxor/Amethyst/releases/download/v1.9.16/amethyst_1.9.16_arm64.deb
sha256sums_aarch64 = 01927aaf04d31e5249e06933e1c78fc624112f034add2f0a3e7767e908dfc52a
source_x86_64 = amethyst-player-1.9.16-x86_64.deb::https://github.com/Geoxor/Amethyst/releases/download/v1.9.16/amethyst_1.9.16_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index e99711d0fcb4..04f9f59c263c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname="${_pkgname}-player-bin"
_appname=Amethyst
pkgver=1.9.16
_electronversion=24
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform music player made with Typescript"
arch=(
"aarch64"
@@ -25,7 +25,7 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('80d12b7c086562e81c66238a2b7c596c335a4da2a047f9880c39ee03b85c28bb'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
sha256sums_aarch64=('01927aaf04d31e5249e06933e1c78fc624112f034add2f0a3e7767e908dfc52a')
sha256sums_x86_64=('2d90947460494f3ba346109d5101b1fbb3c12010fbfd098526f31ba81bc1f1e1')
build() {
@@ -34,7 +34,7 @@ build() {
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
- sed "s|/opt/${_appname}/${_pkgname} %U|${pkgname%-bin}|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g;s|Music;|AudioVideo;|g" \
+ sed "s|/opt/${_appname}/${_pkgname}|${pkgname%-bin}|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g;s|Music;|AudioVideo;|g" \
-i "${srcdir}/usr/share/applications/${_pkgname}.desktop"
}
package() {
diff --git a/amethyst-player.sh b/amethyst-player.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/amethyst-player.sh
+++ b/amethyst-player.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file