summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElijah Gregg2021-02-26 09:05:55 -0700
committerElijah Gregg2021-02-26 09:05:55 -0700
commit00eb0f25d21c0a71315f525a81a71e182d9fd452 (patch)
tree2bc571d6ee7d1c20047f7da931ccc99205ad52a6
downloadaur-00eb0f25d21c0a71315f525a81a71e182d9fd452.tar.gz
Add amfora-favicons-git
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd7842fdb9fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = amfora-favicons-git
+ pkgdesc = Terminal browser for the Gemini protocol
+ pkgver = 1.8.0.r7.ge7c59f1
+ pkgrel = 1
+ url = https://github.com/makeworld-the-better-one/amfora
+ arch = x86_64
+ license = GPL3
+ makedepends = go
+ makedepends = git
+ provides = amfora
+ conflicts = amfora
+ source = git+https://github.com/lovetocode999/amfora-favicons.git
+ md5sums = SKIP
+
+pkgname = amfora-favicons-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e847c7cbb422
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+amfora-favicons/
+pkg/
+src/
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3700afcc05d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Elijah Gregg <lovetocode999@ctrl-c.club>
+pkgname=amfora-favicons-git
+pkgver=1.8.0.r7.ge7c59f1
+pkgrel=1
+pkgdesc="Terminal browser for the Gemini protocol"
+arch=("x86_64")
+url="https://github.com/makeworld-the-better-one/amfora"
+license=("GPL3")
+makedepends=("go" "git")
+provides=("amfora")
+conflicts=("amfora")
+source=("git+https://github.com/lovetocode999/amfora-favicons.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/amfora-favicons"
+
+ _tag=$(git tag --sort=v:refname | tail -n1)
+ printf '%s.r%s.g%s' "${_tag#v}" "$(git rev-list "$_tag"..HEAD --count)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/amfora-favicons"
+
+ make
+}
+
+package() {
+ cd "$srcdir/amfora-favicons"
+
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ make PREFIX="$pkgdir/usr" install
+}