summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2019-10-19 19:33:58 +0200
committerJonas Witschel2019-10-19 19:33:58 +0200
commit4e8afa683e90ee8688106d179a8d35135d17ecb7 (patch)
tree82633423d131d2b9ba18a92a023241abeaca9ade
parentaf3cb32763f0fbe7b0299c49c519bb2e8741572d (diff)
downloadaur-4e8afa683e90ee8688106d179a8d35135d17ecb7.tar.gz
upgpkg: amide 1.0.6-1
- Build from the last (semi-)official sources before development stopped in early 2017, see https://sourceforge.net/p/amide/mailman/message/35615362/ - Remove unnecessary --enable arguments for configure, these are automatically enabled when the necessary dependency is installed (and when it is not installed, explicitly specifying the argument fails silently instead of resulting in an error) - Various small fixes like consistently quoting variables etc.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD42
-rw-r--r--alignment_mutual_information.patch12
-rw-r--r--gsl.patch36
4 files changed, 26 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f564d4202e4..1a78e32aaf31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,21 @@
pkgbase = amide
- pkgdesc = Medical Imaging Data Examiner
- pkgver = 1.0.5
- pkgrel = 10
- url = http://amide.sourceforge.net/packages.html
- arch = i686
+ pkgdesc = Medical imaging data examiner
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = http://amide.sourceforge.net/
arch = x86_64
license = GPL
makedepends = gnome-doc-utils
makedepends = intltool
- makedepends = libgnomecanvas
depends = dcmtk
- depends = xmedcon
- depends = gconf
- depends = gsl
- depends = volpack
+ depends = ffmpeg
depends = gnome-vfs
+ depends = gsl
depends = libgnomecanvas
- options = !makeflags
- source = http://downloads.sourceforge.net/project/amide/amide/1.0.5/amide-1.0.5.tgz
- source = gsl.patch
- source = alignment_mutual_information.patch
- md5sums = 8a9b89e3d3ec1bb3e390f202f4861a7c
- md5sums = 77737953dfcbd9eca4dd7699e79e0bca
- md5sums = fb64f22d5519b38cd832f14f02a7bd39
+ depends = volpack
+ depends = xmedcon
+ source = https://web.stanford.edu/~loening/files/amide-1.0.6-2.fc25.src.rpm
+ sha512sums = 2d6f9d7cfa7921ba95fd0a887504d4ec135d0e93d94ffdf256b5fc94f3df1766006e0f13ca24c1cc7904c636182db96b7e7c29ac2529554c351458217406053d
pkgname = amide
diff --git a/PKGBUILD b/PKGBUILD
index a8cd60045d0e..37195f81b987 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,28 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-
+# Contributor: Jonas Witschel <diabonas@archlinux.org>
pkgname=amide
-pkgver=1.0.5
-pkgrel=10
-pkgdesc="Medical Imaging Data Examiner"
-url="http://amide.sourceforge.net/packages.html"
-arch=('i686' 'x86_64')
+pkgver=1.0.6
+pkgrel=1
+pkgdesc='Medical imaging data examiner'
+arch=('x86_64')
+url='http://amide.sourceforge.net/'
license=('GPL')
-depends=('dcmtk' 'xmedcon' 'gconf' 'gsl' 'volpack' 'gnome-vfs' 'libgnomecanvas')
-makedepends=('gnome-doc-utils' 'intltool' 'libgnomecanvas')
-source=(http://downloads.sourceforge.net/project/$pkgname/amide/$pkgver/$pkgname-$pkgver.tgz gsl.patch alignment_mutual_information.patch)
-md5sums=('8a9b89e3d3ec1bb3e390f202f4861a7c'
- '77737953dfcbd9eca4dd7699e79e0bca'
- 'fb64f22d5519b38cd832f14f02a7bd39')
-options=('!makeflags')
+depends=('dcmtk' 'ffmpeg' 'gnome-vfs' 'gsl' 'libgnomecanvas' 'volpack' 'xmedcon')
+makedepends=('gnome-doc-utils' 'intltool')
+source=('https://web.stanford.edu/~loening/files/amide-1.0.6-2.fc25.src.rpm')
+sha512sums=('2d6f9d7cfa7921ba95fd0a887504d4ec135d0e93d94ffdf256b5fc94f3df1766006e0f13ca24c1cc7904c636182db96b7e7c29ac2529554c351458217406053d')
prepare() {
- cd $pkgname-$pkgver/
- patch -Np1 < "$srcdir"/alignment_mutual_information.patch
- patch -Np1 < "$srcdir"/gsl.patch
+ bsdtar --extract --file "$pkgname-$pkgver.tgz"
}
build() {
- cd $pkgname-$pkgver/
- ./configure --prefix=/usr --disable-ffmpeg --enable-libdcmdata=no \
- --enable-gtk-doc=no --enable-amide-debug=no
- make
- ./configure --prefix=/usr --disable-ffmpeg --enable-libdcmdata \
- --with-xmedcon-exec-prefix=/usr/bin --enable-amide-debug=no
- make
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make --jobs=1
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR=$pkgdir install
- sed -i 's+.png++' "$pkgdir"/usr/share/applications/amide.desktop
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
}
diff --git a/alignment_mutual_information.patch b/alignment_mutual_information.patch
deleted file mode 100644
index 2ff80062cfc9..000000000000
--- a/alignment_mutual_information.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur amide-1.0.5.orig/src/alignment_mutual_information.c amide-1.0.5.new/src/alignment_mutual_information.c
---- amide-1.0.5.orig/src/alignment_mutual_information.c 2012-01-22 17:25:06.000000000 +0100
-+++ amide-1.0.5.new/src/alignment_mutual_information.c 2016-10-29 11:01:50.566415209 +0200
-@@ -209,7 +209,7 @@
- //g_print("\t\%i", mutual_information_array[i][j] ); // for point-wise counts
- // g_print("\t\%4.3f", incremental_mi ); // for point-wise probability
-
-- if isinf(incremental_mi) {
-+ if (isinf(incremental_mi)) {
- //count it (because lots and lots of zeroes mean bad registration) and go to the next loop
- mi_nan_count++;
- // this is most often a problem when the incemental MI is infinity, due to divide by zero
diff --git a/gsl.patch b/gsl.patch
deleted file mode 100644
index fa160e3dc908..000000000000
--- a/gsl.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- amide-1.0.5.old/src/tb_profile.c 2015-11-22 14:00:16.361526795 +0100
-+++ amide-1.0.5/src/tb_profile.c 2015-11-22 14:14:58.993881660 +0100
-@@ -32,6 +32,7 @@
- #include "ui_common.h"
- #ifdef AMIDE_LIBGSL_SUPPORT
- #include <gsl/gsl_multifit_nlin.h>
-+#include <gsl/gsl_version.h>
- #endif
-
-
-@@ -605,6 +606,7 @@
- result_t * result;
- gsl_multifit_fdfsolver * solver;
- gsl_matrix *covar;
-+ gsl_matrix *J;
- gsl_multifit_function_fdf fdf;
- gsl_vector * init_p;
- gint iter;
-@@ -668,8 +670,16 @@
- }
- while ((status == GSL_CONTINUE) && (iter < 100));
-
-+#if GSL_MAJOR_VERSION > 1
-+ {
-+ gsl_matrix *J = gsl_matrix_alloc (result->line->len, num_p);;
-+ gsl_multifit_fdfsolver_jac(solver, J);
-+ gsl_multifit_covar (J, 0.0, covar);
-+ gsl_matrix_free(J);
-+ }
-+#else
- gsl_multifit_covar (solver->J, 0.0, covar);
--
-+#endif
- j=0;
- result->s_fit = gsl_vector_get(solver->x, j++);
- result->p_fit = gsl_vector_get(solver->x, j++);