summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCubeTheThird2020-02-06 23:31:55 -0500
committerCubeTheThird2020-02-06 23:31:55 -0500
commit4d5c755b90fdb249c4b4f1725a5d94bd0a63c14f (patch)
treef9cf1c04315e8d0a0e70b7ed138545e3e9288040
parentf00591649f770f55289f6bae622d7b942c532498 (diff)
downloadaur-4d5c755b90fdb249c4b4f1725a5d94bd0a63c14f.tar.gz
Version bump. Fix for icon.
-rw-r--r--.SRCINFO12
-rw-r--r--ChangeLog17
-rw-r--r--PKGBUILD9
-rw-r--r--amidst.desktop2
4 files changed, 29 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 893373c7f220..a7b7cbd6deaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = amidst
pkgdesc = Advanced Minecraft Interface and Data/Structure Tracking
- pkgver = 4.3
- pkgrel = 2
+ pkgver = 4.4
+ pkgrel = 1
url = https://github.com/toolbox4minecraft/amidst
changelog = ChangeLog
arch = any
@@ -11,11 +11,11 @@ pkgbase = amidst
depends = hicolor-icon-theme
optdepends = minecraft: the game itself
optdepends = minecraft-launcher: The new game launcher
- noextract = amidst-v4-3.jar
- source = https://github.com/toolbox4minecraft/amidst/releases/download/v4.3/amidst-v4-3.jar
+ noextract = amidst-v4-4.jar
+ source = https://github.com/toolbox4minecraft/amidst/releases/download/v4.4/amidst-v4-4.jar
source = amidst.desktop
- md5sums = fd4aeffacf53ab04a6bee9d4711413ee
- md5sums = 3c6900ac68e3175768322e684f9f1bcb
+ md5sums = 6f7c05bd9af84b9d0803b2a393740379
+ md5sums = b56a5d2ba2e3c71ca2c7824d2434d823
pkgname = amidst
diff --git a/ChangeLog b/ChangeLog
index 1bf01d97a177..d70ae66fc242 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,20 @@
+2020-02-06 CubeTheThird <cubethethird@gmail.com>
+
+ * 4.4-1 :
+ Version Bump.
+ Icon fix.
+
+ Upstream Changelog:
+ 4.4:
+ - fix incorrect Stronghold and Pillager Outposts locations
+ - fix broken End generation at large distances from the origin
+ - add Settings > Look & Feel menu item to change the Java Look & Feel of the application
+ 4.4_beta_1
+ - added support up to Minecraft 1.15
+ - add -profile CLI argument to select a starting profile
+ - add -seed and -world-type CLI arguments to select a starting seed
+ - use the native menu bar on OS X
+
2019-07-06 CubeTheThird <cubethethird@gmail.com>
* 4.3-2
diff --git a/PKGBUILD b/PKGBUILD
index 268962e67c13..b05cc02b6e09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Contributor: CubeTheThird <cubethethird@gmail.com>
pkgname=amidst
-_version='4.3'
+_version='4.4'
pkgver=${_version//_/-}
_jarver="v${_version}"
_jarfile="${pkgname}-${_jarver/./-}.jar"
-pkgrel=2
+pkgrel=1
pkgdesc='Advanced Minecraft Interface and Data/Structure Tracking'
arch=('any')
license=('GPL3')
@@ -17,8 +17,8 @@ noextract=("$_jarfile")
changelog=ChangeLog
source=("https://github.com/toolbox4minecraft/amidst/releases/download/$_jarver/$_jarfile"
amidst.desktop)
-md5sums=('fd4aeffacf53ab04a6bee9d4711413ee'
- '3c6900ac68e3175768322e684f9f1bcb')
+md5sums=('6f7c05bd9af84b9d0803b2a393740379'
+ 'b56a5d2ba2e3c71ca2c7824d2434d823')
prepare() {
bsdcpio -i -m --quiet --make-directories '*/amidst-*.png' < "$_jarfile"
@@ -41,6 +41,7 @@ package() {
icon_sizes=(16 32 48 64 128 256)
for s in "${icon_sizes[@]}"; do
+ echo $s
install -Dm644 "amidst/icon/amidst-${s}x${s}.png" "$pkgdir/usr/share/icons/hicolor/${s}x${s}/apps/amidst.png"
done
}
diff --git a/amidst.desktop b/amidst.desktop
index 6f12a2a31da7..a66013977038 100644
--- a/amidst.desktop
+++ b/amidst.desktop
@@ -5,7 +5,7 @@ Name=AMIDST
Comment=Advanced Minecraft Interface and Data/Structure Tracking
TryExec=amidst
Exec=java -noverify -jar /usr/share/java/amidst/AMIDST.jar
-Icon=/usr/share/pixmaps/amidst.png
+Icon=amidst
Terminal=false
Categories=Game;
Keywords=minecraft;