summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcubethethird2016-06-23 16:21:24 -0400
committercubethethird2016-06-23 16:21:24 -0400
commita7d877aedcbc2bfe41ee6ab4f736cda3e089f918 (patch)
treebdbdac131e44a70967cf89a66a9f6e60f90e40e0
parentdc74b2937d8e5da366285673b4249036cad2de58 (diff)
downloadaur-a7d877aedcbc2bfe41ee6ab4f736cda3e089f918.tar.gz
Update to release version 4.1.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--ChangeLog76
-rw-r--r--PKGBUILD31
-rwxr-xr-xamidst.sh2
-rw-r--r--icon.pngbin0 -> 12953 bytes
6 files changed, 106 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8dae74344a72..f02a7a93e6b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = amidst
pkgdesc = Advanced Minecraft Interface and Data/Structure Tracking
- pkgver = 3.7
+ pkgver = 4.1
pkgrel = 1
- url = http://www.minecraftforum.net/topic/626786-
+ url = https://github.com/toolbox4minecraft/amidst
changelog = ChangeLog
arch = any
license = GPL3
- depends = java-runtime
+ depends = java-runtime=8
+ depends = sh
optdepends = minecraft: the game itself
- noextract = AMIDST-3.7.jar
- source = https://github.com/skiphs/AMIDST/releases/download/3.7/AMIDST-3.7.jar
- source = amidst.sh
+ noextract = amidst-v4-1.jar
+ source = https://github.com/toolbox4minecraft/amidst/releases/download/v4.1/amidst-v4-1.jar
source = amidst.desktop
- md5sums = be52f1eaf644fca9c95e1fbe7e2ee5dc
- md5sums = 783c4040c9736f96ce72e9997833a0bf
+ source = icon.png
+ md5sums = 1f3d6157e4d0339ad4f2d7996a0f88a6
md5sums = 3c6900ac68e3175768322e684f9f1bcb
+ md5sums = 0d90c979cbd12aa7d08d05f5f3299ce7
pkgname = amidst
diff --git a/.gitignore b/.gitignore
index c69623988f29..f9926d8009da 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,7 @@
# source files
-mcpatcher-*.jar
+*.jar
+*.pkg.tar.xz
+pkg/**
+src/**
+build.sh
+test.sh
diff --git a/ChangeLog b/ChangeLog
index 58866d87a844..3367f48f70b6 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,4 +1,76 @@
-2015-01-04 Frederik "Freso" S. Olesen <freso.dk@gmail.com>
+2016-06-23 CubeTheThird <cubethethird@gmail.com>
+
+ * 4.1-1 :
+ New contributor.
+ Updated PKGBUILD.
+ Updated URLs for the new amidst git repository
+ Generates the amidst shell script instead of bundling it.
+ Modified java dependency for java 8 requirement.
+ Bundled higher resolution icon.
+ Version bump.
+ See https://github.com/toolbox4minecraft/amidst/releases/tag/v4.1
+
+ Upstream changelog:
+ - added new Ocean Monument algorithm since 15w46a
+ - changed the Slime Chunk color to be better visible in Mushroom Island biomes
+ - fixed the Slime Chunk algorithm
+ - fixed a NullPointerException
+
+ Upstream 4.0 changelog:
+ - New features displayed in the world
+ - igloos
+ - mineshafts
+ - ocean monuments
+ - 1.9 strongholds
+ - the end dimension
+ - the end cities
+ - reduced false positives for villages
+ - increased accuracy of structures
+ - fixed nether fortress locations
+ - fixed player locations for the nether
+ - renamed the biome "Sky" to "The End"
+ - the world spawn is now read from the save game
+ - the player world icons now display the player's current dimension
+ - Player loading, moving and saving
+ - improved workflow for player moving
+ - fixed the player in the sky issue by asking the user for the new y coordinate when a player is moved
+ - fixed player moving context menu on linux (did not show up on right click)
+ - added support for the playerdata directory, which is how players are stored since Minecraft 1.7.6 (saving and loading)
+ - added implementation of another web-service to request player names and skins by uuid
+ - added implementation of another web-service to request player uuids by name
+ - reworked how save games are recognised as single- or multiplayer
+ - GUI
+ - reworked menu structure
+ - reworked keyboard shortcuts and Mnemonics
+ - added new Nether Fortress and Witch Hut icons
+ - added scale widget
+ - added world type to the seed widget
+ - added menu entry switch profile
+ - added menu entry goto spawn
+ - added menu entry reload player locations
+ - added menu entry how can I move a player?
+ - added warning about save game manipulation
+ - debug widget prevented the user to enter the biome highlight mode
+ - updated information in About window
+ - all Operating Systems now use the default Java Look and Feel
+ - made OS X keyboard shortcuts feel more native
+ - Changes under the hood
+ - added information to the seed history file
+ - added useful logging output
+ - changed the update mechanism to work with the new project location
+ - increased the system requirements to Java version 8
+ - improved the command line interface
+ - removed google analytics tracker
+ - removed unused libraries and code
+ - cleaned up the source code
+ - used a code formatter (from eclipse)
+ - added documentation
+ - automated the build process
+ - added tests to ensure the world generation is not changed by accident
+ - changed to new version list URL
+ - updated the cached version list to include all versions up to Minecraft 1.9
+
+ 2015-01-04 Frederik "Freso" S. Olesen <freso.dk@gmail.com>
* 3.7-1 :
Version bump.
@@ -95,7 +167,7 @@
Version bump.
Upstream changelog:
- - Increased performance for filling in image data.
+ - Increased performance for filling in image data.
- Slightly reduce memory usage for structure generation.
- Added official support for 13w37b.
- Reduced memory usage from grid layer.
diff --git a/PKGBUILD b/PKGBUILD
index 769d79c8d0db..1c1faf99ec27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,40 @@
# Maintainer: Frederik "Freso" S. Olesen <archlinux@freso.dk>
+# Contributor: CubeTheThird <cubethethird@gmail.com>
pkgname=amidst
-pkgver='3.7'
-_jarver="${pkgver//_/-}"
-_jarfile="${pkgname^^}-$_jarver.jar"
+_version='4.1'
+pkgver=${_version//_/-}
+_jarver="v${_version}"
+_jarfile="${pkgname}-${_jarver/./-}.jar"
pkgrel=1
pkgdesc='Advanced Minecraft Interface and Data/Structure Tracking'
arch=('any')
license=('GPL3')
-url='http://www.minecraftforum.net/topic/626786-'
-depends=('java-runtime')
+url='https://github.com/toolbox4minecraft/amidst'
+depends=('java-runtime=8' 'sh')
optdepends=('minecraft: the game itself')
noextract=("$_jarfile")
changelog=ChangeLog
-source=("https://github.com/skiphs/AMIDST/releases/download/$_jarver/$_jarfile"
- amidst.sh
- amidst.desktop)
-md5sums=('be52f1eaf644fca9c95e1fbe7e2ee5dc'
- '783c4040c9736f96ce72e9997833a0bf'
- '3c6900ac68e3175768322e684f9f1bcb')
+source=("https://github.com/toolbox4minecraft/amidst/releases/download/$_jarver/$_jarfile"
+ amidst.desktop
+ icon.png)
+md5sums=('1f3d6157e4d0339ad4f2d7996a0f88a6'
+ '3c6900ac68e3175768322e684f9f1bcb'
+ '0d90c979cbd12aa7d08d05f5f3299ce7')
prepare() {
cd "$srcdir"
- # Extract icon
- bsdcpio --extract --make-directories --insecure 'amidst/resources/icon.png' < "$_jarfile"
+ #Create shell script to launch the application
+ echo "#!/bin/sh" > amidst.sh
+ echo "java -noverify -jar /usr/share/java/$pkgname/AMIDST.jar" >> amidst.sh
}
package() {
cd "$srcdir"
install -vDm755 'amidst.sh' "$pkgdir/usr/bin/amidst"
- install -vDm644 'amidst/resources/icon.png' "$pkgdir/usr/share/pixmaps/amidst.png"
+ install -vDm644 'icon.png' "$pkgdir/usr/share/pixmaps/amidst.png"
install -vDm644 'amidst.desktop' "$pkgdir/usr/share/applications/amidst.desktop"
install -vDm644 "$_jarfile" "$pkgdir/usr/share/java/$pkgname/AMIDST.jar"
}
diff --git a/amidst.sh b/amidst.sh
deleted file mode 100755
index f4154b9c9175..000000000000
--- a/amidst.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-java -noverify -jar /usr/share/java/amidst/AMIDST.jar
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..2b41a87422f5
--- /dev/null
+++ b/icon.png
Binary files differ