summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquellen2017-05-29 23:47:50 +0200
committerquellen2017-05-29 23:47:50 +0200
commitbe8e00367989979a29ba745ed0ac75516eae96e4 (patch)
tree21930e35964806d602f2710f41a6f834c5afd4cb
downloadaur-be8e00367989979a29ba745ed0ac75516eae96e4.tar.gz
useful commit message
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c89aad57cd1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = amitools
+ pkgdesc = Various AmigaOS tools for other platforms
+ pkgver = r.
+ pkgrel = 1
+ url = https://github.com/cnvogelg/amitools
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python-lhafile
+ depends = python2
+ depends = cython2
+ source = git+https://github.com/cnvogelg/amitools.git
+ md5sums = SKIP
+ sha256sums = SKIP
+
+pkgname = amitools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63219ac857d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: quellen <lodgerz@gmail.com>
+pkgname=amitools
+pkgver=r.
+pkgrel=1
+pkgdesc="Various AmigaOS tools for other platforms"
+arch=('i686' 'x86_64')
+url="https://github.com/cnvogelg/amitools"
+license=('GPL')
+depends=('python-lhafile' 'python2' 'cython2')
+source=("git+https://github.com/cnvogelg/amitools.git")
+md5sums=('SKIP')
+sha256sums=('SKIP')
+pkgver() {
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ cd "${pkgname}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${pkgname}"
+ python2 setup.py install --root="$pkgdir/" --prefix=/usr
+} \ No newline at end of file