summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThatOneCalculator2021-05-27 23:34:37 -0700
committerThatOneCalculator2021-05-27 23:34:37 -0700
commitccf17aece964f6597f1f40a2b66cb0bd74c94e8d (patch)
tree9dc8c8679248366d9da32655145b3b65c4b908cb
downloadaur-ccf17aece964f6597f1f40a2b66cb0bd74c94e8d.tar.gz
1.4.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8971bf918318
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = among-us-dumpy-gif-maker
+ pkgdesc = A tool that lets you make Among Us Dumpy GIFs
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/ThatOneCalculator/Among-Us-Dumpy-Gif-Maker
+ arch = x86_64
+ license = GPL
+ depends = jdk-openjdk
+ depends = imagemagick
+ noextract = Among-Us-Dumpy-Gif-Maker-1.4.0-all.jar
+ noextract = among-us-dumpy-gif-maker
+ source_x86_64 = Among-Us-Dumpy-Gif-Maker-1.4.0-all.jar::https://github.com/ThatOneCalculator/Among-Us-Dumpy-Gif-Maker/releases/download/v1.4.0/Among-Us-Dumpy-Gif-Maker-1.4.0-all.jar
+ source_x86_64 = among-us-dumpy-gif-maker::https://raw.githubusercontent.com/ThatOneCalculator/Among-Us-Dumpy-Gif-Maker/main/among-us-dumpy-gif-maker
+ sha256sums_x86_64 = SKIP
+ sha256sums_x86_64 = SKIP
+
+pkgname = among-us-dumpy-gif-maker
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbbdb4a8b4e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kainoa Kanter <kainoa@t1c.dev>
+# Based off of: https://daveparrish.net/posts/2019-11-16-Better-AppImage-PKGBUILD-template.html
+
+_pkgname="among-us-dumpy-gif-maker"
+_pkgver="1.4.0"
+_jar="Among-Us-Dumpy-Gif-Maker-${_pkgver}-all.jar"
+
+pkgname="${_pkgname}"
+pkgver="${_pkgver}"
+pkgrel=1
+pkgdesc="A tool that lets you make Among Us Dumpy GIFs"
+arch=("x86_64")
+url="https://github.com/ThatOneCalculator/Among-Us-Dumpy-Gif-Maker"
+license=("GPL")
+depends=("jdk-openjdk" "imagemagick")
+source_x86_64=("${_jar}::https://github.com/ThatOneCalculator/Among-Us-Dumpy-Gif-Maker/releases/download/v${_pkgver}/${_jar}" "${_pkgname}::https://raw.githubusercontent.com/ThatOneCalculator/Among-Us-Dumpy-Gif-Maker/main/among-us-dumpy-gif-maker")
+noextract=("${_jar}" "${_pkgname}")
+sha256sums_x86_64=("SKIP" "SKIP")
+
+prepare() {
+ chmod +x "${_pkgname}"
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "${srcdir}/${_jar}" "${pkgdir}/usr/share/${_jar}"
+}