summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrego Dadone2016-06-28 03:27:21 -0300
committerGrego Dadone2016-06-28 03:27:21 -0300
commit295051686195708f19e4777020895771ae7fa760 (patch)
treed8c95902abd5f4a211880eee41d7e5104c361281
downloadaur-295051686195708f19e4777020895771ae7fa760.tar.gz
First commit
-rwxr-xr-x.SRCINFO20
-rwxr-xr-xPKGBUILD31
-rwxr-xr-xamor.install11
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..25907bd6d079
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = amor
+ pkgdesc = On-Screen Creature
+ pkgver = 15.08.3
+ pkgrel = 1
+ url = https://projects.kde.org/projects/kde/kdetoys/amor
+ install = amor.install
+ arch = i686
+ arch = x86_64
+ groups = kde-applications
+ license = GPL
+ license = LGPL
+ license = FDL
+ makedepends = cmake
+ makedepends = automoc4
+ depends = kdebase-runtime
+ source = http://download.kde.org/stable/applications/15.08.3/src/amor-15.08.3.tar.xz
+ sha1sums = d8e4550e987a6df59abf75f22df99b3fab1e8ed3
+
+pkgname = amor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e4e748c075f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Grego Dadone <GregoD at archlinux.org>
+# Contributor: Andrea Scarpino <andrea at archlinux.org>
+
+pkgname=amor
+pkgver=15.08.3
+pkgrel=1
+pkgdesc='On-Screen Creature'
+url='https://projects.kde.org/projects/kde/kdetoys/amor'
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL' 'FDL')
+groups=('kde-applications')
+depends=('kdebase-runtime')
+makedepends=('cmake' 'automoc4')
+install=${pkgname}.install
+source=("http://download.kde.org/stable/applications/${pkgver}/src/amor-${pkgver}.tar.xz")
+sha1sums=('d8e4550e987a6df59abf75f22df99b3fab1e8ed3')
+
+build() {
+ mkdir -p build
+ cd build
+ cmake ../amor-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE4_BUILD_TESTS=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR=$pkgdir install
+} \ No newline at end of file
diff --git a/amor.install b/amor.install
new file mode 100755
index 000000000000..ca53cb02c157
--- /dev/null
+++ b/amor.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}