summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Sarboni2015-07-17 16:17:34 +0200
committerThomas Sarboni2015-07-17 16:21:46 +0200
commit8c5b67602f0ade9fee963b37515ee84c7e5a4071 (patch)
tree281693d3e372f29f444d5c24e10f427ad15f67fb
downloadaur-8c5b67602f0ade9fee963b37515ee84c7e5a4071.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
-rw-r--r--ampache.install17
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b16f0af484c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ampache
+ pkgdesc = A PHP-based tool for managing and playing your audio/video files via a web interface
+ pkgver = 3.8.0
+ pkgrel = 1
+ url = http://www.ampache.org/
+ install = ampache.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = mariadb>=5.0
+ depends = php>=5.3
+ optdepends = lame: all transcoding/downsampling
+ optdepends = vorbis-tools: all transcoding
+ optdepends = flac: flac transcoding/downsampling
+ optdepends = faad2: m4a transcoding/downsampling
+ optdepends = mp3splt: mp3 and ogg transcoding/downsampling
+ conflicts = ampache-git
+ conflicts = ampache-development
+ source = https://github.com/ampache/ampache/archive/3.8.0.tar.gz
+ sha256sums = 10a167b162af9b0f2c17a6cf0d92bbc6fc3c80b4be802d77defcfe761f177304
+
+pkgname = ampache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86da58a6b1e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Maintainer: max-k <max-k AT post DOT com>
+#Contributor: Zavon <zavon at zavon dot org>
+#Contributor: Jonathan 'gishten' Gustafsson <mynick AT mynick DOT com>
+#Contributor: Diego <cdprincipe@gmail.com
+pkgname=ampache
+pkgver=3.8.0
+pkgrel=1
+pkgdesc="A PHP-based tool for managing and playing your audio/video files via a web interface"
+arch=('i686' 'x86_64')
+url="http://www.ampache.org/"
+license=('GPL')
+depends=('mariadb>=5.0' 'php>=5.3')
+optdepends=('lame: all transcoding/downsampling'
+ 'vorbis-tools: all transcoding'
+ 'flac: flac transcoding/downsampling'
+ 'faad2: m4a transcoding/downsampling'
+ 'mp3splt: mp3 and ogg transcoding/downsampling')
+conflicts=('ampache-git' 'ampache-development')
+install=${pkgname}.install
+source=(https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz)
+sha256sums=('10a167b162af9b0f2c17a6cf0d92bbc6fc3c80b4be802d77defcfe761f177304')
+
+build() {
+ echo "" > /dev/null
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ mkdir -p ${pkgdir}/srv/http/${pkgname}
+ cp -a * ${pkgdir}/srv/http/${pkgname}/
+}
diff --git a/ampache.install b/ampache.install
new file mode 100644
index 000000000000..0495a081783d
--- /dev/null
+++ b/ampache.install
@@ -0,0 +1,17 @@
+post_install() {
+ cat <<-EndOfMessage
+ ==> If you want to use Ampache's transcoding and/or downsampling you'll
+ need the packages specified in optdepends.
+ Check out http://wiki.archlinux.org/index.php/Ampache and
+ https://github.com/ampache/ampache/wiki/Transcoding for more info.
+ ==> Please enable curl and pdo_mysql modules in php.ini.
+ ==> Database will be upgraded automatically in case of update from 3.7.
+ Check out https://github.com/ampache/ampache/wiki/Installation for
+ more info about installation process.
+ EndOfMessage
+ /bin/true
+}
+
+post_upgrade() {
+ post_install
+}