summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Mielniczuk2019-07-01 18:13:14 +0200
committerMarcin Mielniczuk2019-07-01 18:13:14 +0200
commit313c98c466fdba74a1c1386523c973c68c09dacf (patch)
tree00bf80332294ec2a6fd15f31b5442cf1b887d1dd
parent76eba9e2cc1077fa448240aa858c5e70ace18484 (diff)
downloadaur-313c98c466fdba74a1c1386523c973c68c09dacf.tar.gz
Enable charmdebug
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0d9021cf427..c4d506c1d154 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ampi-openmpi
pkgdesc = Adaptive Message Passing Interface, OpenMPI backend
pkgver = 6.9.0
- pkgrel = 2
+ pkgrel = 3
url = http://charm.cs.uiuc.edu/research/ampi/
arch = x86_64
license = custom:Charm++/Converse License
diff --git a/PKGBUILD b/PKGBUILD
index 89aee1af9e53..f618d82fa361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_backend=openmpi
pkgname=ampi-${_backend}
pkgver=6.9.0
-pkgrel=2
+pkgrel=3
pkgdesc="Adaptive Message Passing Interface, OpenMPI backend"
arch=('x86_64')
license=('custom:Charm++/Converse License')
@@ -11,10 +11,11 @@ depends=('openmpi')
makedepends=('gcc-fortran')
source=("http://charm.cs.illinois.edu/distrib/charm-${pkgver}.tar.gz")
sha512sums=('894d154b7d8a8757e76838d97b0fd969fd4fa874956c80af7ea0766687272bbbe7df342b7e5d77e460ea883185de8b0f8f9926548e6ef4b9b8ed00e3caef94d2')
+_ENABLE_FEATURES="--enable-charmdebug"
build() {
cd charm-${pkgver}
- ./build AMPI mpi-linux-x86_64 --with-production
+ ./build AMPI mpi-linux-x86_64 ${_ENABLE_FEATURES} --with-production
}
package() {