summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSauyon Lee2023-03-11 20:37:50 -0800
committerSauyon Lee2023-03-11 20:38:19 -0800
commit6adff4d4b0cb30f61dbb75c2b8f18464207a536d (patch)
tree9a2ee03969aa9637d395f0de17b8643eacd76f83
parentfc1fc2b5c55d6ab0c438935e7eb6089bbadde0f7 (diff)
downloadaur-6adff4d4b0cb30f61dbb75c2b8f18464207a536d.tar.gz
working version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
-rw-r--r--sysusers.conf2
-rw-r--r--tmpfiles.conf1
4 files changed, 32 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92e0ed848cdb..a5418a887b36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,27 @@
pkgbase = ampinstmgr
pkgdesc = AMP (Application Management Panel) is a simple to use and easy to install control panel and management system for hosting game servers.
pkgver = 2.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://cubecoders.com/AMP
arch = i686
arch = x86_64
license = unknown
- depends = lib32-glibc
- depends = lib32-gcc-libs
depends = tmux
depends = socat
depends = dnsutils
depends = jq
depends = qrencode
+ depends = mono
optdepends = jre8-openjdk-headless
optdepends = jre-openjdk-headless
+ optdepends = steamcmd
+ optdepends = docker
+ options = !strip
source = http://repo.cubecoders.com/ampinstmgr-2.4.2.x86_64.tgz
+ source = sysusers.conf
+ source = tmpfiles.conf
sha256sums = 18005b8fb9696d746d150b58aafec7c125c6e52c8e3adcf871db7200c5b53901
+ sha256sums = 54478340926d4f49dd784c7cffe8e191a0b5b1dc29b72694f02b40a9672d9237
+ sha256sums = 5c6a673550c8243556e2c770c8e85f5892cdee334d063e49aa398175b00fce11
pkgname = ampinstmgr
diff --git a/PKGBUILD b/PKGBUILD
index 239d18941ff2..2834333b419d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,47 @@
# Maintainer: Sauyon Lee <sauyon@setsuna>
pkgname=ampinstmgr
pkgver=2.4.2
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="AMP (Application Management Panel) is a simple to use and easy to install control panel and management system for hosting game servers."
arch=('i686' 'x86_64')
url="https://cubecoders.com/AMP"
license=(unknown)
groups=()
-depends=(lib32-glibc lib32-gcc-libs tmux socat dnsutils jq qrencode)
+depends=(tmux socat dnsutils jq qrencode mono)
makedepends=()
checkdepends=()
-optdepends=(jre8-openjdk-headless jre-openjdk-headless)
+optdepends=(jre8-openjdk-headless jre-openjdk-headless steamcmd docker)
provides=()
conflicts=()
replaces=()
backup=()
-options=()
+options=(!strip)
install=
changelog=
-source=("http://repo.cubecoders.com/$pkgname-$pkgver.x86_64.tgz")
-sha256sums=('18005b8fb9696d746d150b58aafec7c125c6e52c8e3adcf871db7200c5b53901')
-
+source=("http://repo.cubecoders.com/$pkgname-$pkgver.x86_64.tgz"
+ sysusers.conf
+ tmpfiles.conf
+ )
+sha256sums=('18005b8fb9696d746d150b58aafec7c125c6e52c8e3adcf871db7200c5b53901'
+ '54478340926d4f49dd784c7cffe8e191a0b5b1dc29b72694f02b40a9672d9237'
+ '5c6a673550c8243556e2c770c8e85f5892cdee334d063e49aa398175b00fce11')
noextract=()
package() {
cd "$srcdir/"
cp -r . "$pkgdir/"
+
rm "$pkgdir/$pkgname-$pkgver.x86_64.tgz"
+
+ # move system units to the correct place
+ install -dm755 "$pkgdir/usr/lib"
+ mv "$pkgdir/etc/systemd" "$pkgdir/usr/lib"
+
+ # add amp user
+ install -Dm644 sysusers.conf "$pkgdir/usr/lib/sysusers.d/ampinstmgr.conf"
+ install -Dm644 tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/ampinstmgr.conf"
}
# vim:set ts=2 sw=2 et:
diff --git a/sysusers.conf b/sysusers.conf
new file mode 100644
index 000000000000..e9313bfaba2b
--- /dev/null
+++ b/sysusers.conf
@@ -0,0 +1,2 @@
+u amp /bin/bash "User for the AMP game server" /var/lib/amp
+m amp tty
diff --git a/tmpfiles.conf b/tmpfiles.conf
new file mode 100644
index 000000000000..e62b5ee895b8
--- /dev/null
+++ b/tmpfiles.conf
@@ -0,0 +1 @@
+d /var/lib/amp 0755 amp amp - -