summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorguidobelix2015-06-16 20:18:59 +0200
committerguidobelix2015-06-16 20:18:59 +0200
commit9488a5c1d2098da5ab38f2ef2ff663bc1bd3f154 (patch)
tree608752ccb6989776cb51c23c7135964322614f9d
downloadaur-9488a5c1d2098da5ab38f2ef2ff663bc1bd3f154.tar.gz
First commit to Aur4 + added systemd files
new file: .SRCINFO new file: PKGBUILD new file: amule.install new file: amuled.systemd new file: amuleweb.systemd new file: fix_icon+comment+name2.patch
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD79
-rw-r--r--amule.install31
-rw-r--r--amuled.systemd11
-rw-r--r--amuleweb.systemd13
-rw-r--r--fix_icon+comment+name2.patch15
6 files changed, 179 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d24343d42be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = amule-adnza-svn
+ pkgdesc = aMule patched for Fastweb Network (Italy) by Adunanza forum - SVN development branch
+ pkgver = 546
+ pkgrel = 1
+ url = http://amule-adunanza.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ license = GPL
+ makedepends = subversion
+ depends = wxgtk
+ depends = wxgtk2.8
+ depends = gd
+ depends = geoip
+ depends = libupnp
+ depends = crypto++
+ depends = libsm
+ provides = amule
+ conflicts = amule
+ conflicts = amule-adnza
+ source = fix_icon+comment+name2.patch
+ source = amuled.systemd
+ source = amuleweb.systemd
+ md5sums = cef300135ba532b171db957ccff0311a
+ md5sums = 59772c41860e238f1c822feb8ca8d47f
+ md5sums = 05975c5d94bfc41fddb894d98b1115d5
+
+pkgname = amule-adnza-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a50e837ddee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Mantainer: Guidobelix <guidobelix AT hotmail DOT it>
+# Contributor: Mattia Bertoni <mattia DOT b89 AT gmail DOT com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: erm67
+# Contributor: ntia89
+# Contributor: mattia.b89 <mattia DOT b89 AT gmail DOT com>
+# Contributor: Hilinus
+#
+
+pkgname=amule-adnza-svn
+pkgver=546
+pkgrel=1
+pkgdesc="aMule patched for Fastweb Network (Italy) by Adunanza forum - SVN development branch"
+url='http://amule-adunanza.sourceforge.net/'
+license=('GPL')
+arch=('i686' 'x86_64' 'arm' 'armv7h')
+depends=('wxgtk' 'wxgtk2.8' 'gd' 'geoip' 'libupnp' 'crypto++' 'libsm')
+makedepends=('subversion')
+conflicts=('amule' 'amule-adnza')
+provides=('amule')
+source=(
+ 'fix_icon+comment+name2.patch'
+ 'amuled.systemd'
+ 'amuleweb.systemd')
+md5sums=(
+ 'cef300135ba532b171db957ccff0311a'
+ '59772c41860e238f1c822feb8ca8d47f'
+ '05975c5d94bfc41fddb894d98b1115d5')
+
+_svntrunk=https://svn.code.sf.net/p/amule-adunanza/code/branches/MoonRiver/
+_svnmod=mrhydeit
+
+configureopts=(
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-cas \
+ --enable-wxcas \
+ --enable-amule-daemon \
+ --enable-amulecmd \
+ --enable-amule-gui \
+ --enable-alc \
+ --enable-alcc \
+ --enable-webserver \
+ --disable-debug \
+ --enable-optimize \
+ --enable-ccache \
+ --enable-geoip \
+ --enable-upnp \
+ --with-wxversion=2.8
+)
+
+build() {
+
+ cd "${srcdir}"
+
+ if [ -d "${_svnmod}/.svn" ]; then
+ (cd "${_svnmod}" && svn up -r "${pkgver}")
+ else
+ svn co "${_svntrunk}" --config-dir ./ -r "${pkgver}" "${_svnmod}"
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "${srcdir}/${_svnmod}-build"
+ cp -r "${_svnmod}" "${_svnmod}-build"
+ cd "${_svnmod}-build"
+
+ patch -Np0 -i "${srcdir}/fix_icon+comment+name2.patch"
+
+ ./autogen.sh
+ ./configure "${configureopts[@]}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_svnmod}-build"
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/amule.install b/amule.install
new file mode 100644
index 000000000000..000b996dbbbe
--- /dev/null
+++ b/amule.install
@@ -0,0 +1,31 @@
+post_install() {
+ post_upgrade
+ passwd -l amule &>/dev/null
+}
+
+_config_instructions() {
+ echo "If you plan to use external client (e.g. amuleGUI or amuleweb) then you need to"
+ echo "provide [ExternalConnect] configuration."
+ echo "You also need to specify amuleweb password."
+ echo "amuleweb can be started as 'systemctl start amuleweb'."
+ echo "Please follow https://wiki.archlinux.org/index.php/AMule for more information."
+ echo "Visit http://forum.adunanza.net/ if you need support."
+ echo "Please note that this is the development version, therefore it has to be considered UNSTABLE!"
+ }
+
+post_upgrade() {
+ # create user/group that the daemon will run as by default, do not delete this on uninstall, as it will own files
+ getent group amule >/dev/null || groupadd amule
+ getent passwd amule >/dev/null || useradd -c 'aMule Client' -g amule -d '/var/lib/amule' -m -s /bin/false amule
+
+ if [ ! -e /var/lib/amule/.aMule/amule.conf ]; then
+ _config_instructions
+ fi
+}
+
+post_remove() {
+ # TOTHINK: delete homedir and user account/group?
+ #getent passwd amule >/dev/null && userdel amule
+ #getent group amule >/dev/null && groupdel amule
+ true
+}
diff --git a/amuled.systemd b/amuled.systemd
new file mode 100644
index 000000000000..e1878dfd9759
--- /dev/null
+++ b/amuled.systemd
@@ -0,0 +1,11 @@
+[Unit]
+Description=aMule Daemon
+After=network.target
+
+# This assumes that a user 'amule' exists, with a writeable home directory
+[Service]
+User=amule
+ExecStart=/usr/bin/amuled
+
+[Install]
+WantedBy=multi-user.target
diff --git a/amuleweb.systemd b/amuleweb.systemd
new file mode 100644
index 000000000000..1799f4ae88c0
--- /dev/null
+++ b/amuleweb.systemd
@@ -0,0 +1,13 @@
+[Unit]
+Description=aMule Webserver
+Requires=amuled.service
+
+[Service]
+User=amule
+ExecStart=/usr/bin/amuleweb --quiet
+# If amuled still starting then amuleweb exits, restart until amuleweb is up
+Restart=on-success
+RestartSec=3s
+
+[Install]
+WantedBy=multi-user.target
diff --git a/fix_icon+comment+name2.patch b/fix_icon+comment+name2.patch
new file mode 100644
index 000000000000..662847acfa58
--- /dev/null
+++ b/fix_icon+comment+name2.patch
@@ -0,0 +1,15 @@
+--- amuleadunanza.desktop.orig 2012-06-07 19:36:03.211473241 +0200
++++ amuleadunanza.desktop 2012-06-07 19:40:38.417586425 +0200
+@@ -1,7 +1,10 @@
+ [Desktop Entry]
+-Name=aMule-AdunanzA
++Name=aMule AdunanzA
++GenericName=aMule Client
+ Exec=amule
+-Icon=amuleadunanza
++Icon=amule
+ Terminal=false
+ Type=Application
+ Categories=Network;P2P;
++Comment=Download and share your files via KADU network
++Comment[it]=Scarica e condividi i tuoi file attraverso la rete KADU