summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin Ruoshui2019-03-16 10:40:33 +0000
committerLin Ruoshui2019-03-16 10:40:33 +0000
commit2fcc7e66464945420a9ac4b56d07f27e868c4949 (patch)
tree0abd03c99bedc6243f21083f732099e5185ae330
parent0ea0caf2f479bc5a1a78803904bdcaa352de6b3b (diff)
downloadaur-2fcc7e66464945420a9ac4b56d07f27e868c4949.tar.gz
add systemd unit from community/amule and remove unused patch files
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD70
-rw-r--r--amule.sysusers1
-rw-r--r--amule.tmpfiles1
-rw-r--r--amuled.systemd12
-rw-r--r--amuleweb.systemd13
6 files changed, 79 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce48282a2d8d..453189e66333 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,31 @@
-# Generated by mksrcinfo v8
-# Tue Aug 7 02:37:26 UTC 2018
pkgbase = amule-git
pkgdesc = Client for the eD2k and Kad networks
- pkgver = 2.3.2.r49.dc0f6c6f7
+ pkgver = 2.3.2.r64.20afd75fa
pkgrel = 1
url = http://amule.org/
- arch = i686
arch = x86_64
- license = GPL
- makedepends = autoconf
- makedepends = automake
- makedepends = boost
+ license = GPL2
makedepends = git
- makedepends = pkg-config
+ makedepends = ccache
+ makedepends = boost
depends = boost-libs
depends = crypto++
depends = geoip
depends = libupnp
depends = wxgtk2
+ depends = gd
+ depends = boost-libs
conflicts = amule
source = git+https://github.com/amule-project/amule.git
- source = https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/amuled@.service
- source = https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/use_xdg-open_as_preview_default.diff
- source = https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/version_check.diff
+ source = amuled.systemd
+ source = amuleweb.systemd
+ source = amule.sysusers
+ source = amule.tmpfiles
sha256sums = SKIP
- sha256sums = b8ade9930c00c411958758a2f8267c0a56320270fc06b2ee15243a027795745d
- sha256sums = 902f8f719c1c02335880621717f23c683da8edbb31add75d3e1267b190e03b9c
- sha256sums = 7bf39a64a723ab3e55ccfef93df2ec9cdd8108e56aa0733a4412755931cb3244
+ sha256sums = 20ac6b60c5f3bf49c0b080dfc02409da3c9d01b154344188008c6a75ca69681e
+ sha256sums = f4f43b1154ddccc9036a4291a58c6715f097b171fec62ea7aead0c9d9fa654f2
+ sha256sums = c4ca658ab4105b3b90e0bb3efcc8121eca1c4d873787db1ed4f637925c16d502
+ sha256sums = e9d1b7019c7075b0f8616c6507a767b87de8f899936680e9ff5829d8cbba224d
pkgname = amule-git
diff --git a/PKGBUILD b/PKGBUILD
index 48318ff88754..6c5d5a6c1c36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,52 @@
+# Maintainer: LIN Ruoshui <lin dot ruohshoei plus archlinux at gmail dot com>
+# Contributor: lukpod
+
pkgname=amule-git
-pkgver=2.3.2.r49.dc0f6c6f7
+pkgver=2.3.2.r64.20afd75fa
pkgrel=1
pkgdesc="Client for the eD2k and Kad networks"
-arch=(i686 x86_64)
+arch=('x86_64')
url=http://amule.org/
-license=(GPL)
-depends=(boost-libs crypto++ geoip libupnp wxgtk2)
-makedepends=(autoconf automake boost git pkg-config)
+license=(GPL2)
+depends=(boost-libs crypto++ geoip libupnp wxgtk2 gd boost-libs)
+makedepends=(git ccache boost)
conflicts=(amule)
source=(
git+https://github.com/amule-project/amule.git
-#https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/use_xdg-open_as_preview_default.diff
-#https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/version_check.diff
-https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/amuled@.service
-https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/use_xdg-open_as_preview_default.diff
-https://gitlab.com/palopezv/aur-amule-git-patches/raw/master/version_check.diff
+#git+https://repo.or.cz/amule.git
+amuled.systemd amuleweb.systemd amule.sysusers amule.tmpfiles
)
sha256sums=('SKIP'
- 'b8ade9930c00c411958758a2f8267c0a56320270fc06b2ee15243a027795745d'
- '902f8f719c1c02335880621717f23c683da8edbb31add75d3e1267b190e03b9c'
- '7bf39a64a723ab3e55ccfef93df2ec9cdd8108e56aa0733a4412755931cb3244')
+ '20ac6b60c5f3bf49c0b080dfc02409da3c9d01b154344188008c6a75ca69681e'
+ 'f4f43b1154ddccc9036a4291a58c6715f097b171fec62ea7aead0c9d9fa654f2'
+ 'c4ca658ab4105b3b90e0bb3efcc8121eca1c4d873787db1ed4f637925c16d502'
+ 'e9d1b7019c7075b0f8616c6507a767b87de8f899936680e9ff5829d8cbba224d')
pkgver() {
cd amule/
- git describe | sed 's/-/.r/; s/-g/./'
-}
-
-prepare() {
- cd amule/
- patch -Np1 <$srcdir/use_xdg-open_as_preview_default.diff
- patch -Np1 <$srcdir/version_check.diff
+ git describe --tags | sed 's/-/.r/; s/-g/./'
}
build() {
cd amule/
./autogen.sh
- local confargs=(
- --disable-debug
- --disable-rpath
- --enable-alcc
- --enable-geoip
- --enable-mmap
- --enable-optimize
- --prefix=/usr
- --with-boost
- )
- ./configure ${confargs[@]}
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-cas \
+ --enable-wxcas \
+ --enable-amule-daemon \
+ --enable-amulecmd \
+ --enable-amule-gui \
+ --enable-alc \
+ --enable-alcc \
+ --enable-webserver \
+ --disable-debug \
+ --enable-optimize \
+ --enable-ccache \
+ --enable-geoip \
+ --enable-upnp \
+ --enable-fileview \
+ --with-boost
make
}
@@ -54,5 +55,10 @@ check() {
}
package() {
- make -C amule/ DESTDIR=$pkgdir install
+ cd amule
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir"/amuled.systemd "$pkgdir"/usr/lib/systemd/system/amuled.service
+ install -Dm644 "$srcdir"/amuleweb.systemd "$pkgdir"/usr/lib/systemd/system/amuleweb.service
+ install -Dm644 "$srcdir"/amule.sysusers "$pkgdir"/usr/lib/sysusers.d/amule.conf
+ install -Dm644 "$srcdir"/amule.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/amule.conf
}
diff --git a/amule.sysusers b/amule.sysusers
new file mode 100644
index 000000000000..4f46b42f258a
--- /dev/null
+++ b/amule.sysusers
@@ -0,0 +1 @@
+u amule - "aMule Client" /var/lib/amule
diff --git a/amule.tmpfiles b/amule.tmpfiles
new file mode 100644
index 000000000000..7f74ba8c4416
--- /dev/null
+++ b/amule.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/amule 0750 amule amule
diff --git a/amuled.systemd b/amuled.systemd
new file mode 100644
index 000000000000..e4ac5713b9b7
--- /dev/null
+++ b/amuled.systemd
@@ -0,0 +1,12 @@
+[Unit]
+Description=aMule Daemon
+After=network.target
+
+# This assumes that a user 'amule' exists, with a writeable home directory
+[Service]
+User=amule
+ExecStart=/usr/bin/amuled
+NoNewPrivileges=true
+
+[Install]
+WantedBy=multi-user.target
diff --git a/amuleweb.systemd b/amuleweb.systemd
new file mode 100644
index 000000000000..1799f4ae88c0
--- /dev/null
+++ b/amuleweb.systemd
@@ -0,0 +1,13 @@
+[Unit]
+Description=aMule Webserver
+Requires=amuled.service
+
+[Service]
+User=amule
+ExecStart=/usr/bin/amuleweb --quiet
+# If amuled still starting then amuleweb exits, restart until amuleweb is up
+Restart=on-success
+RestartSec=3s
+
+[Install]
+WantedBy=multi-user.target