summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlukpod2015-10-15 22:41:02 +0200
committerlukpod2015-10-15 22:41:02 +0200
commitab936ceda2135c086d72d85dc177579aaec1a0d7 (patch)
tree94aaed0a28d4dc0e37fbbedcf9c715b36ebdaf55
parentcaaa20bbeb611fb226bcd194a786cdbb4c742028 (diff)
downloadaur-ab936ceda2135c086d72d85dc177579aaec1a0d7.tar.gz
Added options to build with Boost.Asio networking (see whole PKGBUILD to enable)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
-rw-r--r--amule.install11
3 files changed, 16 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3feaca3b213d..dbd1108b58b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = amule-git
pkgdesc = Client for the eD2k and Kad networks
pkgver = 2.4.0.r10287.34c7d73
- pkgrel = 1
+ pkgrel = 2
url = http://amule.org/
- install = amule.install
arch = i686
arch = x86_64
license = GPL
makedepends = git
depends = crypto++
- depends = desktop-file-utils
depends = gd
depends = geoip
depends = libupnp
@@ -21,7 +19,6 @@ pkgbase = amule-git
source = git+https://github.com/amule-project/amule.git
source = http://svgicons.o7a.net/unofficial/amule.png
source = https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/configure_ignore_gdlib-config_garbage.diff
- source = https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/mime-ed2k-protocol.patch
source = https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/use_xdg-open_as_preview_default.diff
source = https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/version_check.diff
source = https://raw.githubusercontent.com/microcai/gentoo-zh/master/net-p2p/amule-dlp/files/amule-dlp-scanner-header.patch
@@ -30,7 +27,6 @@ pkgbase = amule-git
sha256sums = SKIP
sha256sums = 737873e5f29dabaca6f9ac96b612eda8cba0236b6618e380107ea7d1d7665b78
sha256sums = 505f70995a56d748f853265fba84a1bbdfbb0291195842b69e76370013239a6e
- sha256sums = 255d99552136712416b3270bb26d2622d1f0d3724891457e4221e67431a0606f
sha256sums = 902f8f719c1c02335880621717f23c683da8edbb31add75d3e1267b190e03b9c
sha256sums = 0904ff6a1dfa298f452332831345feb4aa6575668a8b092b3cc6edfbfed974fe
sha256sums = 04db8bbb57834174148c48da4f02832c413a8911eb5ace0ee11190990b875ff9
diff --git a/PKGBUILD b/PKGBUILD
index b42a0341e7a6..fd0ef42ca748 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,31 @@
pkgname=amule-git
pkgver=2.4.0.r10287.34c7d73
-pkgrel=1
+pkgrel=2
pkgdesc='Client for the eD2k and Kad networks'
arch=(i686 x86_64)
url=http://amule.org/
license=(GPL)
-depends=(crypto++ desktop-file-utils gd geoip libupnp wxgtk2.8)
-makedepends=(git)
+depends=(
+# boost-libs
+ crypto++
+ gd
+ geoip
+ libupnp
+ wxgtk2.8
+ )
+makedepends=(
+# boost
+ git
+)
+#makedepends=(boost git)
provides=(amule)
conflicts=(amule)
backup=(usr/share/webapps/amps/index.php
usr/share/webapps/amps/style.css)
-install=amule.install
source=(
git+https://github.com/amule-project/amule.git
http://svgicons.o7a.net/unofficial/amule.png
https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/configure_ignore_gdlib-config_garbage.diff
-https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/mime-ed2k-protocol.patch
https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/use_xdg-open_as_preview_default.diff
https://anonscm.debian.org/cgit/pkg-amule/amule.git/plain/debian/patches/version_check.diff
https://raw.githubusercontent.com/microcai/gentoo-zh/master/net-p2p/amule-dlp/files/amule-dlp-scanner-header.patch
@@ -26,7 +35,6 @@ https://raw.githubusercontent.com/pld-linux/aMule/master/build.patch
sha256sums=(SKIP
737873e5f29dabaca6f9ac96b612eda8cba0236b6618e380107ea7d1d7665b78
505f70995a56d748f853265fba84a1bbdfbb0291195842b69e76370013239a6e
- 255d99552136712416b3270bb26d2622d1f0d3724891457e4221e67431a0606f
902f8f719c1c02335880621717f23c683da8edbb31add75d3e1267b190e03b9c
0904ff6a1dfa298f452332831345feb4aa6575668a8b092b3cc6edfbfed974fe
04db8bbb57834174148c48da4f02832c413a8911eb5ace0ee11190990b875ff9
@@ -50,7 +58,6 @@ prepare() {
patch -Np1 < $srcdir/amule-dlp-scanner-header.patch
patch -Np1 < $srcdir/build.patch
patch -Np1 < $srcdir/configure_ignore_gdlib-config_garbage.diff
- patch -Np1 < $srcdir/mime-ed2k-protocol.patch
patch -Np1 < $srcdir/use_xdg-open_as_preview_default.diff
patch -Np1 < $srcdir/version_check.diff
@@ -80,6 +87,7 @@ build() {
--enable-webserver
--enable-xas
--prefix=/usr
+# --with-boost
--with-wx-config=wx-config-2.8
)
diff --git a/amule.install b/amule.install
deleted file mode 100644
index df3df28afe33..000000000000
--- a/amule.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- update-desktop-database
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}