summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordanitool2015-09-15 18:12:45 +0200
committerdanitool2015-09-15 18:12:45 +0200
commit723a1bba0ee92acea6f761e695bcf45171a01cc8 (patch)
treef9a00ba3ecbbb6f6c2d4cb74ec3ae973baf6329f
downloadaur-723a1bba0ee92acea6f761e695bcf45171a01cc8.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rwxr-xr-xPKGBUILD38
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c89593075771
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by makepkg 4.2.1
+# Tue Sep 15 16:11:01 UTC 2015
+pkgbase = amulegui-upnp
+ pkgdesc = Remote GUI for the aMule Daemon, an eMule-like client for the ed2k p2p network
+ pkgver = 10871
+ pkgrel = 1
+ url = http://www.amule.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = crypto++
+ depends = wxgtk>=2.8.0
+ depends = gd>=2.0.34
+ depends = binutils>=2.17.50.0.18
+ depends = geoip>=1.4.4
+ depends = libupnp>=1.6.6
+ provides = amulegui=10871
+ conflicts = amule
+ conflicts = amule-svn
+ conflicts = amule-noupnp-svn
+ conflicts = amule-noupnp
+ source = http://amule.sourceforge.net/tarballs/aMule-SVN-r10871.tar.bz2
+ md5sums = f3c666b6fa518a3e6e2c21670c243292
+
+pkgname = amulegui-upnp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..5ecdc78b1d7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Tudhalyas <tudhalyas_AT_gmail_DOT_com>
+# Contributor: danitool <dgcbueu_AT_gmail_DOT_com>
+
+pkgname=amulegui-upnp
+pkgver=10871
+pkgrel=1
+pkgdesc="Remote GUI for the aMule Daemon, an eMule-like client for the ed2k p2p network"
+arch=('i686' 'x86_64')
+url="http://www.amule.org/"
+license=('GPL')
+depends=('wxgtk>=2.8.0' 'gd>=2.0.34' 'binutils>=2.17.50.0.18' 'geoip>=1.4.4' 'libupnp>=1.6.6')
+makedepends=('crypto++')
+conflicts=('amule' 'amule-svn' 'amule-noupnp-svn' 'amule-noupnp')
+provides=("amulegui=${pkgver}")
+source=(http://amule.sourceforge.net/tarballs/aMule-SVN-r${pkgver}.tar.bz2)
+md5sums=('f3c666b6fa518a3e6e2c21670c243292')
+
+build() {
+ cd ${srcdir}/aMule-SVN-r${pkgver}
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-optimize \
+ --enable-amule-gui \
+ --disable-cas \
+ --disable-alcc \
+ --enable-upnp \
+ --enable-geoip \
+ --disable-monolithic \
+ --disable-wxcas \
+ --disable-alc \
+ --disable-debug
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/aMule-SVN-r${pkgver}
+ make DESTDIR=${pkgdir}/ install || return 1
+}