summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCranky Supertoon2020-09-10 16:05:00 -0400
committerCranky Supertoon2020-09-10 16:05:00 -0400
commitf903bf694a1a4233232dc9d54a80cc769c1e13df (patch)
tree709f56b8469e218511c6c1502dc4e33373363fff
parentd9f9e68b7735e3ea85f95a5402e3021f5b529a22 (diff)
downloadaur-f903bf694a1a4233232dc9d54a80cc769c1e13df.tar.gz
Start work on Fixing Amulet AUR Package, still need stuff from their side
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d850307cfe0d..6ff45ac8e33b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = amulet-map-editor-bin
pkgdesc = A new Minecraft world editor and converter that supports all versions since Java 1.12 and Bedrock 1.7.
- pkgver = 0.6.10.0
+ pkgver = 0.7.0.1
pkgrel = 1
url = https://www.amulet-editor.com/
arch = x86_64
@@ -8,7 +8,8 @@ pkgbase = amulet-map-editor-bin
makedepends = gendesk
makedepends = dos2unix
makedepends = wget
- source_x86_64 = Amulet-v0.6.10.0-linux.zip::https://github.com/Amulet-Team/Amulet-Map-Editor/releases/download/v0.6.10.0/Amulet-v0.6.10.0-linux.zip
+ depends = libpng
+ source_x86_64 = Amulet-v0.7.0.1-linux.zip::https://github.com/Amulet-Team/Amulet-Map-Editor/releases/download/v0.7.0.1/Amulet-v0.7.0.1-linux.zip
md5sums_x86_64 = SKIP
pkgname = amulet-map-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
index 52875f29c2a4..9cfa1ca70f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Cranky Supertoon <crankysupertoon@gmail.com>
pkgname="amulet-map-editor-bin"
-pkgver="0.6.10.0"
+pkgver="0.7.0.1"
pkgrel=1
arch=('x86_64')
pkgdesc="A new Minecraft world editor and converter that supports all versions since Java 1.12 and Bedrock 1.7."
url="https://www.amulet-editor.com/"
license=('MIT')
makedepends=('gendesk' 'dos2unix' 'wget')
-
+depends=('libpng')
source_x86_64=(
"Amulet-v${pkgver}-linux.zip::https://github.com/Amulet-Team/Amulet-Map-Editor/releases/download/v${pkgver}/Amulet-v${pkgver}-linux.zip"
)
@@ -37,7 +37,7 @@ package() {
# install the icon
install -d -m755 "${pkgdir}/usr/share/icons"
- cp -Rr "${srcdir}/Amulet/amulet_map_editor/img/icon128.png" "${pkgdir}/usr/share/icons/${pkgname}.png"
+ cp -Rr "${srcdir}/Amulet/amulet_map_editor/api/image/logo/icon128.png" "${pkgdir}/usr/share/icons/${pkgname}.png"
# fix file permissions - all files as 644 - directories as 755
find "${pkgdir}/"{opt,usr} -type d -exec chmod 755 {} \;